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Warnings, Cautions, and Notes 

Warning 

Warning notices are used in this publication to emphasize that hazardous voltages, 

currents, temperatures, or other conditions that could cause personal injury exist in this 

equipment or may be associated with its use. In situations where inattention could cause 

either personal injury or damage to equipment, a Warning notice is used.  

 
■ Installing or removing modules or wiring with power applied to the system or field wiring 

can cause an electrical arc. This can result in unexpected and potentially dangerous 
action by field devices. Arcing is an explosion risk in hazardous locations. Be sure that the 
area is non-hazardous or remove power appropriately before installing or removing 
modules or wiring. 

■ Potentially dangerous voltages are present on a module’s terminals, even when system 
power is turned off. Field power must be turned off when installing or removing a terminal 
block assembly. 

■ Personnel, who install, operate and maintain automation systems that contain these 
products must be trained and qualified to perform those functions. 

■ Overloading power modules or Network adapter can result into electric arc & damage to 
modules. 

Caution 

Caution notices are used where equipment might be damaged if care is not taken. 

 

■ Check the rated voltage and terminal array before wiring. 
■ Ensure that specified environmental conditions are not exceeded. Avoid placing the 

module in direct sunlight. 
■ Review module specifications carefully, and ensure that input and output connections are 

made in accordance with the specifications. 
■ Use specified cables for wiring.  
■ Field power isolators must be used according to the requirements of the 

5VDC/24VDC/48VDC or AC Voltage modules used in the system. 
■ If system power consumption exceeds the power limits, use system power expansion 

modules. 
■ Make sure power supplies for system power and field power must be supplied from 

separate sources. 
 

  



Note: Notes merely call attention to information that is especially significant to 
understanding and operating the equipment. 

This document is based on information available at the time of its publication.  While efforts 
have been made to be accurate, the information contained herein does not purport to cover all 
details or variations in hardware or software, or to provide for every possible contingency in 
connection with installation, operation, or maintenance.  Features may be described herein 
which are not present in all hardware and software systems.  GE Intelligent Platforms assumes 
no obligation of notice to holders of this document with respect to changes subsequently made. 

GE Intelligent Platforms makes no representation or warranty, expressed, implied, or statutory 
with respect to, and assumes no responsibility for the accuracy, completeness, sufficiency, or 
usefulness of the information contained herein.  No warranties of merchantability or fitness for 
purpose shall apply. 
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If you purchased this product through an Authorized Channel Partner, please contact the seller 

directly. 

General Contact Information 

Online technical support and Global 

Care 

http://support.ge-ip.com 

Additional information http://www.ge-ip.com/ 

Solution Provider solutionprovider.ip@ge.com 

Technical Support 

If you have technical problems that cannot be resolved with the information in this manual, please 

contact us by telephone or email, or on the web at http://support.ge-ip.com 

Americas 

Online Technical Support http://support.ge-ip.com 

Phone 1-800-433-2682 

International Americas Direct Dial 1-780-420-2010 (if toll free 800 option is unavailable) 

Technical Support Email support.ip@ge.com 

Customer Care Email customercare.ip@ge.com 

Primary language of support English 

Europe, the Middle East, and Africa 

Online Technical Support http://support.ge-ip.com 

Phone +800-1-433-2682 

EMEA Direct Dial +352-26-722-780 (if toll free 800 option is unavailable or if 

dialing from a mobile telephone) 

Technical Support Email support.emea.ip@ge.com 

Customer Care Email customercare.emea.ip@ge.com 

Primary languages of support English, French, German, Italian, Czech, Spanish 

Asia Pacific 

Online Technical Support http://support.ge-ip.com 

Phone +86-400-820-8208 

+86-21-3217-4826 (India, Indonesia, and Pakistan) 

Technical Support Email support.cn.ip@ge.com (China) 

support.jp.ip@ge.com (Japan) 

support.in.ip@ge.com (remaining Asia customers) 

Customer Care Email customercare.apo.ip@ge.com, 

customercare.cn.ip@ge.com (China) 

http://support.ge-ip.com/
http://www.ge-ip.com/
mailto:solutionprovider.ip@ge.com
http://support.ge-ip.com/
http://support.ge-ip.com/
mailto:support.ip@ge.com
mailto:customercare.ip@ge.com
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mailto:support.emea.ip@ge.com
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Introduction 
 

The PACSystems RSTi Network Interface and I/O family provides a low cost, modular 

distributed I/O system. The RSTi network is ideally suited for distributed applications such 

as water/wastewater, process control, packaging and assembly. You can easily add RSTi 

modules to the system to build functional remote I/O stations to meet your application 

requirements. 

 

 

 

 

Sr. Number Label 

 
Removable Switch of Terminal Block 

 
Tester Pin Hole 

 
Screw less Connection System 

 
I/O Status Display LED 
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Sr. Number Label 

 
System-Data Pin (6 Pins) 

 
Module Number Marking (Header Type) 

 
Header Type Module (16 points) 

 
Field Power Pin (2 pins) 

 
RTB (Removable Terminal Block) 

 
Reserved communication Port (Useful to only 
manufacturer) 

 
PUSH Lock for DIN rail 

 
Fieldbus Connector 

 
Module Number Marking (on the Removable terminal 
Block 

   

Node ID or station address setting 

 

A set of interconnected RSTi modules can be chosen to suit the application and 

connected as a slave on a PROFIBUS or a PROFINET network. An RSTi PROFIBUS or 

PROFINET Network Adapter provides the interface between the network and the RSTi 

modules. The Network Adapter and I/O modules selected for an application constitute an 

I/O station. 
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I/O Station Capacity 

 Up to 32 IO devices can be connected to a Network Adapter (STXPBS001, 

STXPNS001) whereas. PROFIBUS network adapters with integrated IO support only 

up to 8 IO modules. The power consumption of all the modules in the node should be 

calculated and ensured that it does not exceed the capacity of Network Adapter and 

power modules.  

 The sum of all input and output data can be up to: 

 504 bytes per station for a PROFINET network 

 256 bytes per station for a PROFIBUS network  

 The maximum number of I/O stations per RX3i Profinet controller is 128 and for Rx3i 

profibus Controller is 125 

Network Topology 

For PROFIBUS networks, I/O stations can be connected via linear bus architecture with 

active bus termination at both ends. Devices in a PROFIBUS network connect directly to 

the bus cable or indirectly via stub lines. 

For PROFINET networks, I/O stations can be connected using either linear or star 

architecture. 

Installation 

The Network Adapter must be connected to the left of the other RSTi modules in the I/O 

station. 

Within the RSTi station the bus connection, power supply, and power distribution are 

completed by connecting modules together on the DIN rail. Sensors and actuators are 

wired to the RSTi modules using spring clamp terminals on the module’s removable 

terminal strips. These terminal strips can be keyed so that they cannot be accidentally 

swapped. If a module must be replaced, the wiring does not need to be removed; just 

remove the terminal strip from the module. 

An All-in-One PROFIBUS Network Adapter that includes built-in digital I/O is available. It 

combines the advantages of slice-type and block-type construction and offers reduced 

system design and maintenance costs. You can add up to eight IO modules to the All-in-

One adapter. 

Features 

 Modules can be easily installed and connected without tools. 

 Flexible and modular structure allows I/O stations to be easily expanded. 

 A comprehensive selection of I/O modules supports a wide range of applications.  

 Small removable terminal blocks conserve panel space and save time making system 

connections. 

 By using Pin Slide way for stable system configuration, the contact between modules 

can be maximized after module connection. 

 Module-based diagnostic functions 

 The amount of costly parallel wiring is reduced. Within a station, voltage and data 

routing can be carried out without additional wiring, reducing the cabinet space 

needed. 
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 Different parts of the system can be operated independent of one another. This 

means that pretests can be carried out when the system is set up and that the whole 

system can be adapted and expanded.  

List of RSTi Network adapters 
RSTi: 

PROFIBUS Network Adapters: 

■ STXPBS001 PROFIBUS DP/V1 network adapter 

■ STXPBS032 32 point Positive Logic Input 

■ STXPBS132 32 point Negative Logic Input 

■ STXPBS232 32 point Negative Logic Output 

■ STXPBS332 32 point Positive Logic Output 

■ STXPBS016 16 relay output 

■ STXPBS116 16 relay output isolated 

■ STXPBS432 16 Positive Logic in/16 Negative Logic out 

■ STXPBS532 16 Negative Logic in/16 Negative Logic out 

■ STXPBS824 16 Positive Logic in/16 relay out 

■ STXPBS924 16 Negative Logic in/16 relay out 

■ STXPBS825 16 Positive Logic in/16 relay out isolated 

■ STXPBS925 16 Negative Logic in/16 relay out isolated 

 

PROFINET Network Adapter 

■ STXPNS001 PROFINET network adapter 

PACSystem Documentation  
 

■ PACSystem RSTi I/O Manual – GFK 2745
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Installation 
 

Module Mounting 

How to mount on Din-Rail 

1. Press down the module lightly on the Din-Rail until it clicks. 

 

 
 

2. Press down till you can hear “click” for complicated mount. You can use the PUSH 

lock for DIN rail up as a second locking mechanism. 
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How to dismount from Din-Rail 

1. Ensure that the PUSH lock for DIN rail is pulled below. Pull down the locking 

mechanism by using small flat screw driver as the following pictures; 

 

 
 

2. Pull up the module to remove from the din rail. 
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PROFIBUS Network Adapters 
 

PROFIBUS Network Adapters include STXPBS001 and STXPBS* modules. 

 

■ STXPBS001 

The following are the features of STXPBS001: 

 STXPBS001 is connected with the PROFIBUS-DP by means of 9 Pin D-sub 

Connector. 

 It works as a slave in the Master/Slave environment. 

 The node size is able to extend up to 32 IO modules units. 

 Each STXPBS001 can control maximum 1024 digital input/1024 digital output, or 

64 analog input/64 analog output channels. 

 LED indicators for diagnostic functions (the status of Module, network expansion 

units, and field power)  

 It has got the PNO conformance certificate. This means it has interoperability with 

other PROFIBUS products.  

 It supports the communication speed from 9.6Kbps to 12Mbps and the auto baud 

rate detection.  

 The station number is assigned by rotary switch. 

 

■ STXPBS* 

 The following are the features of STXPBS*: 

 STXPBS* supports PROFIBUS communication protocol and is connected with 

PROFIBUS by means of 9 Pin open Connector.  

 These modules work as a slave under Master/Slave circumstances.  

 They allow I/O Data communications with Master by means of polling process. 

 They support the transmission rate from 9.6Kbps to 12Mbps and Auto Baudrate 

Detection.  

 They also define the Node Address and communication speed by using Dip 

Switch. 

 

 

 

*  indicates STXPBS032/132/232/332/016/116/432/532/824/924/825/925. 
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STXPBS001 

Interface and Data 

The following screenshot shows the interface diagram for STXPBS001. 

 
Figure 1: PROFIBUS Network Adaptor Module: STXPBS001 

 
The following table lists the pin numbers and their description for STXPBS001. 
 

Table 1: STXPBS001: Pin Description 

Pin Number Description Pin Number Description 

0 System power 24v 1 System power 0 v 

2 Ground 3 Ground 

4 Field power 0v 5 Field power 0v 

6 Field power 24v 7 Field power 24v 
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Specification 
The following table describes the Specifications of STXPBS001. 
 

Table 2: STXPBS001: Interface and General Specifications 

Items Specification 

Interface Specification 

Redundancy Not supported 

Repeater Control Signal RS-485 Signal 

Freeze mode Support 

Sync mode  Support 

Auto baud rate Support 

Fail safe mode Support 

Station type Slave 

FMS support Not supported 

Number of Station 100 Station/Max (Rotary switch #0~99) 

Number of Expansion I/O slots Maximum 32 slots 

I/O Data Size Total: Input 128bytes/Output 128bytes 

 Maximum Discrete I/O: Input 1024points/Output 
1024points 

 Maximum Analog I/O: Input 64channels/Output 
64channels 

Indicators 1 green/red Module Status Indicator 

1 green Network Status Indicator 

1 green/red IO Module Status indicator 

1 green Field Power Status indicator 

Baud Rate 9.6K~12M (1.2Km~100m) (Auto baud rate Selection) 

Module Location Starter module - First side of RSTi system 

Field Power detection Detect Field Power @ minimum 11Vdc 

General Specification 

Surrounding Air Temperature/  

Ambient Temperature 

-20℃—50℃ for UL applications. -20℃ to 60℃ for non UL 

applications. Storage -40℃—85℃ 

Relative Humidity 5% ~ 90%, without condensation 

Durable-vib./impact IEC68-2-6(2G)/10G at non-driving 

EMC/ESD EN50082/EN50081 

Mount Position First module of RSTi system 

Atmosphere No excessive dust , No corrosive gases 

Field Supply Voltage Class 2, 24VDC 

24VDC (11VDC ~ 28.8VDC) 

Field Supply Current Maximum 10A 

Mount DIN-Rail 

System Power  Supply voltage: 24Vdc nominal 

Supply voltage range: 11~28.8Vdc 

Protection: Output current limit (Minimum 1.5A) 

Reverse polarity protection 

Power Dissipation 60mA typical @24Vdc 

Current for I/O Module 1.5A @5Vdc 
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Isolation System power to internal logic: Non-isolation 

System power to I/O driver: Isolation 

Field Power Supply voltage: 24Vdc nominal 

Supply voltage range: 11~28.8Vdc 

Maximum Current Field Power Contact DC 10A Maximum 

Weight 155g 

Module Size 42mm x 99mm x 70mm 

Certification UL/cUL/CE/PROFIBUS (PNO)  

Environment Condition See “Environmental Specifications" in Appendix A. 

Technical Specification 

Network Type PROFIBUS-DP 

Network Cable PROFIBUS-DP Special Cable 

Cable Length 1.2Km ~ 100m 

Communication Speed 9.6kBaud ~ 12MBaud 

Maximum Station No. 99 Station (Include Master Scanner) 

Station Type PROFIBUS-DP Slave 

Expansion No. Maximum 32 Module 

Maximum Digital I/O Input: 1024point / Output: 1024point 

Maximum Analog I/O Input: 64Ch/Output: 64Ch 

I/O Data Size Input: 128Bytes / Output: 128Bytes 

Baud rate Setting Support Auto-baud rate 

Station No. Setting Rotary S/W #1, #2 (x10, x1) 

Power Dissipation 60mA 
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STXPBS* 

Interface and Data 

STXPBS032 – Profibus Network Adapter with32 point Positive Logic Input  

The following screenshot shows the interface diagram for STXPBS032. 

 

 
Figure 2: PROFIBUS Network Adaptor Module: STXPBS032 

 
The following table lists the pin numbers and their description for STXPBS032. 
 

Table 3: STXPBS032: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Input Channel 16 

01-1 Input Channel 1 03-1 Input Channel 17 

01-2 Input Channel 2 03-2 Input Channel 18 

01-3 Input Channel 3 03-3 Input Channel 19 

01-4 Input Channel 4 03-4 Input Channel 20 

01-5 Input Channel 5 03-5 Input Channel 21 

01-6 Input Channel 6 03-6 Input Channel 22 

01-7 Input Channel 7 03-7 Input Channel 23 

02-0 Input Channel 8 04-0 Input Channel 24 

02-1 Input Channel 9 04-1 Input Channel 25 

02-2 Input Channel 10 04-2 Input Channel 26 

02-3 Input Channel 11 04-3 Input Channel 27 

02-4 Input Channel 12 04-4 Input Channel 28 
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02-5 Input Channel 13 04-5 Input Channel 29 

02-6 Input Channel 14 04-6 Input Channel 30 

02-7 Input Channel 15 04-7 Input Channel 31 
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STXPBS132- Profibus Network Adapter with 32 point Negative Logic Input  

 

The following screenshot shows the interface diagram for STXPBS132. 

 

 
Figure 3: PROFIBUS Network Adaptor Module: STXPBS132 

 
The following table lists the pin numbers and their description for STXPBS132. 
 

Table 4: STXPBS132: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Input Channel 16 

01-1 Input Channel 1 03-1 Input Channel 17 

01-2 Input Channel 2 03-2 Input Channel 18 

01-3 Input Channel 3 03-3 Input Channel 19 

01-4 Input Channel 4 03-4 Input Channel 20 

01-5 Input Channel 5 03-5 Input Channel 21 

01-6 Input Channel 6 03-6 Input Channel 22 

01-7 Input Channel 7 03-7 Input Channel 23 

02-0 Input Channel 8 04-0 Input Channel 24 

02-1 Input Channel 9 04-1 Input Channel 25 

02-2 Input Channel 10 04-2 Input Channel 26 

02-3 Input Channel 11 04-3 Input Channel 27 

02-4 Input Channel 12 04-4 Input Channel 28 

02-5 Input Channel 13 04-5 Input Channel 29 

02-6 Input Channel 14 04-6 Input Channel 30 
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02-7 Input Channel 15 04-7 Input Channel 31 

STXPBS232- Profibus Network Adapter with 32 point Negative Logic Output  

The following screenshot shows the interface diagram for STXPBS232. 

 

 
Figure 4: PROFIBUS Network Adaptor Module: STXPBS232 

 
The following table lists the pin numbers and their description for STXPBS232. 
 

Table 5: STXPBS232: Pin Description 

Pin Number Description Pin Number Description 

01-0 Output Channel 0 03- 0 Output Channel 16 

01-1 Output Channel 1 03-1 Output Channel 17 

01-2 Output Channel 2 03-2 Output Channel 18 

01-3 Output Channel 3 03-3 Output Channel 19 

01-4 Output Channel 4 03-4 Output Channel 20 

01-5 Output Channel 5 03-5 Output Channel 21 

01-6 Output Channel 6 03-6 Output Channel 22 

01-7 Output Channel 7 03-7 Output Channel 23 

02-0 Output Channel 8 04-0 Output Channel 24 

02-1 Output Channel 9 04-1 Output Channel 25 

02-2 Output Channel 10 04-2 Output Channel 26 

02-3 Output Channel 11 04-3 Output Channel 27 

02-4 Output Channel 12 04-4 Output Channel 28 

02-5 Output Channel 13 04-5 Output Channel 29 

02-6 Output Channel 14 04-6 Output Channel 30 
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02-7 Output Channel 15 04-7 Output Channel 31 

STXPBS332- Profibus Network Adapter with32 point Positive Logic Output  

 

The following screenshot shows the interface diagram for STXPBS332. 

 

 
Figure 5: PROFIBUS Network Adaptor Module: STXPBS332 

 
The following table lists the pin numbers and their description for STXPBS332. 
 

Table 6: STXPBS332: Pin Description 

Pin Number Description Pin Number Description 

01-0 Output Channel 0 03- 0 Output Channel 16 

01-1 Output Channel 1 03-1 Output Channel 17 

01-2 Output Channel 2 03-2 Output Channel 18 

01-3 Output Channel 3 03-3 Output Channel 19 

01-4 Output Channel 4 03-4 Output Channel 20 

01-5 Output Channel 5 03-5 Output Channel 21 

01-6 Output Channel 6 03-6 Output Channel 22 

01-7 Output Channel 7 03-7 Output Channel 23 

02-0 Output Channel 8 04-0 Output Channel 24 

02-1 Output Channel 9 04-1 Output Channel 25 

02-2 Output Channel 10 04-2 Output Channel 26 

02-3 Output Channel 11 04-3 Output Channel 27 

02-4 Output Channel 12 04-4 Output Channel 28 
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02-5 Output Channel 13 04-5 Output Channel 29 

02-6 Output Channel 14 04-6 Output Channel 30 

02-7 Output Channel 15 04-7 Output Channel 31 
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STXPBS016- Profibus Network Adapter with16 relay output  

 

The following screenshot shows the interface diagram for STXPBS016. 

 

 
Figure 6: PROFIBUS Network Adaptor Module: STXPBS016 

 
The following table lists the pin numbers and their description for STXPBS016. 
 

Table 7: STXPBS016: Pin Description 

Pin Number Description Pin Number Description 

01-0 Relay Output 0 03- 0 Relay Output 8 

01-1 COM 0 03-1 COM 2 

01-2 Relay Output 1 03-2 Relay Output 9 

01-3 COM 0 03-3 COM 2 

01-4 Relay Output 2 03-4 Relay Output 10 

01-5 COM 0 03-5 COM 2 

01-6 Relay Output 3 03-6 Relay Output 11 

01-7 COM 0 03-7 COM 2 

02-0 Relay Output 4 04-0 Relay Output 12 

02-1 COM 1 04-1 COM 3 

02-2 Relay Output 5 04-2 Relay Output 13 

02-3 COM 1 04-3 COM 3 

02-4 Relay Output 6 04-4 Relay Output 14 

02-5 COM 1 04-5 COM 3 

02-6 Relay Output 7 04-6 Relay Output 15 
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2-7 COM 1 4-7 COM 3 

STXPBS116- Profibus Network Adapter with 16 relay output isolated  

 

The following screenshot shows the interface diagram for STXPBS116. 

 

 
Figure 7: PROFIBUS Network Adaptor Module: STXPBS116 

 
The following table lists the pin numbers and their description for STXPBS116. 
 

Table 8: STXPBS116: Pin Description 

Pin Number Description Pin Number Description 

01-0 Relay Output 0 03- 0 Relay Output 8 

01-1 COM 0 03-1 COM 8 

01-2 Relay Output 1 03-2 Relay Output 9 

01-3 COM 1 03-3 COM 9 

01-4 Relay Output 2 03-4 Relay Output 10 

01-5 COM 2 03-5 COM 10 

01-6 Relay Output 3 03-6 Relay Output 11 

01-7 COM 3 03-7 COM 11 

02-0 Relay Output 4 04-0 Relay Output 12 

02-1 COM 4 04-1 COM 12 

02-2 Relay Output 5 04-2 Relay Output 13 

02-3 COM 5 04-3 COM 13 

02-4 Relay Output 6 04-4 Relay Output 14 
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02-5 COM 6 04-5 COM 14 

02-6 Relay Output 7 04-6 Relay Output 15 

02-7 COM 7 04-7 COM 15 

STXPBS432- Profibus Network Adapter with 16 Positive Logic in/16 Negative Logic out  

 

The following screenshot shows the interface diagram for STXPBS432. 

 

 
Figure 8: PROFIBUS Network Adaptor Module: STXPBS432 

 
The following table lists the pin numbers and their description for STXPBS432. 
 

Table 9: STXPBS432: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Output Channel 0 

01-1 Input Channel 1 03-1 Output Channel 1 

01-2 Input Channel 2 03-2 Output Channel 2 

01-3 Input Channel 3 03-3 Output Channel 3 

01-4 Input Channel 4 03-4 Output Channel 4 

01-5 Input Channel 5 03-5 Output Channel 5 

01-6 Input Channel 6 03-6 Output Channel 6 

01-7 Input Channel 7 03-7 Output Channel 7 

02-0 Input Channel 8 04-0 Output Channel 8 

02-1 Input Channel 9 04-1 Output Channel 9 

02-2 Input Channel 10 04-2 Output Channel 10 
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02-3 Input Channel 11 04-3 Output Channel 11 

02-4 Input Channel 12 04-4 Output Channel 12 

02-5 Input Channel 13 04-5 Output Channel 13 

02-6 Input Channel 14 04-6 Output Channel 14 

02-7 Input Channel 15 04-7 Output Channel 15 

STXPBS532- Profibus Network Adapter with 16 Negative Logic in/16 Negative Logic out  

 

The following screenshot shows the interface diagram for STXPBS532. 

 

 
Figure 9: PROFIBUS Network Adaptor Module: STXPBS532 

 
The following table lists the pin numbers and their description for STXPBS532. 
 

Table 10: STXPBS532: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Output Channel 0 

01-1 Input Channel 1 03-1 Output Channel 1 

01-2 Input Channel 2 03-2 Output Channel 2 

01-3 Input Channel 3 03-3 Output Channel 3 

01-4 Input Channel 4 03-4 Output Channel 4 

01-5 Input Channel 5 03-5 Output Channel 5 

01-6 Input Channel 6 03-6 Output Channel 6 

01-7 Input Channel 7 03-7 Output Channel 7 

02-0 Input Channel 8 04-0 Output Channel 8 
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02-1 Input Channel 9 04-1 Output Channel 9 

02-2 Input Channel 10 04-2 Output Channel 10 

02-3 Input Channel 11 04-3 Output Channel 11 

02-4 Input Channel 12 04-4 Output Channel 12 

02-5 Input Channel 13 04-5 Output Channel 13 

02-6 Input Channel 14 04-6 Output Channel 14 

02-7 Input Channel 15 04-7 Output Channel 15 

STXPBS824- Profibus Network Adapter with 16 Positive Logic in/16 relay out  

 

The following screenshot shows the interface diagram for STXPBS824. 

 

 
Figure 10: PROFIBUS Network Adaptor Module: STXPBS824 

 
The following table lists the pin numbers and their description for STXPBS824. 
 

Table 11: STXPBS824: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Relay Output 0 

01-1 Input Channel 1 03-1 COM 0 

01-2 Input Channel 2 03-2 Relay Output 1 

01-3 Input Channel 3 03-3 COM 1 

01-4 Input Channel 4 03-4 Relay Output 2 

01-5 Input Channel 5 03-5 COM 2 

01-6 Input Channel 6 03-6 Relay Output 3 
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01-7 Input Channel 7 03-7 COM 3 

02-0 Input Channel 8 04-0 Relay Output 4 

02-1 Input Channel 9 04-1 COM 4 

02-2 Input Channel 10 04-2 Relay Output 5 

02-3 Input Channel 11 04-3 COM 5 

02-4 Input Channel 12 04-4 Relay Output 6 

02-5 Input Channel 13 04-5 COM 6 

02-6 Input Channel 14 04-6 Relay Output 7 

02-7 Input Channel 15 04-7 COM 7 

STXPBS924- Profibus Network Adapter with 16 Negative Logic in/16 relay out  

 

The following screenshot shows the interface diagram for STXPBS924. 

 

 
Figure 11: PROFIBUS Network Adaptor Module: STXPBS924 

 
The following table lists the pin numbers and their description for STXPBS924. 
 

Table 12: STXPBS924: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Relay Output 0 

01-1 Input Channel 1 03-1 COM 0 

01-2 Input Channel 2 03-2 Relay Output 1 

01-3 Input Channel 3 03-3 COM 0 

01-4 Input Channel 4 03-4 Relay Output 2 
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01-5 Input Channel 5 03-5 COM 0 

01-6 Input Channel 6 03-6 Relay Output 3 

01-7 Input Channel 7 03-7 COM 0 

02-0 Input Channel 8 04-0 Relay Output 4 

02-1 Input Channel 9 04-1 COM 1 

02-2 Input Channel 10 04-2 Relay Output 5 

02-3 Input Channel 11 04-3 COM 1 

02-4 Input Channel 12 04-4 Relay Output 6 

02-5 Input Channel 13 04-5 COM 1 

02-6 Input Channel 14 04-6 Relay Output 7 

02-7 Input Channel 15 04-7 COM 1 

STXPBS825- Profibus Network Adapter with 16 Positive Logic in/16 relay out isolated  

 

The following screenshot shows the interface diagram for STXPBS825. 

 

 
Figure 12: PROFIBUS Network Adaptor Module: STXPBS825 

 
The following table lists the pin numbers and their description for STXPBS825. 
 

Table 13: STXPBS825: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Relay Output 0 

01-1 Input Channel 1 03-1 COM 0 

01-2 Input Channel 2 03-2 Relay Output 1 
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01-3 Input Channel 3 03-3 COM 1 

01-4 Input Channel 4 03-4 Relay Output 2 

01-5 Input Channel 5 03-5 COM 2 

01-6 Input Channel 6 03-6 Relay Output 3 

01-7 Input Channel 7 03-7 COM 3 

02-0 Input Channel 8 04-0 Relay Output 4 

02-1 Input Channel 9 04-1 COM 4 

02-2 Input Channel 10 04-2 Relay Output 5 

02-3 Input Channel 11 04-3 COM 5 

02-4 Input Channel 12 04-4 Relay Output 6 

02-5 Input Channel 13 04-5 COM 6 

02-6 Input Channel 14 04-6 Relay Output 7 

02-7 Input Channel 15 04-7 COM 7 

STXPBS925- Profibus Network Adapter with 16 Negative Logic in/16 relay out isolated  

 

The following screenshot shows the interface diagram for STXPBS925. 

 

 
Figure 13: PROFIBUS Network Adaptor Module: STXPBS925 

 
The following table lists the pin numbers and their description for STXPBS925. 
 

Table 14: STXPBS925: Pin Description 

Pin Number Description Pin Number Description 

01-0 Input Channel 0 03- 0 Relay Output 0 
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01-1 Input Channel 1 03-1 COM 0 

01-2 Input Channel 2 03-2 Relay Output 1 

01-3 Input Channel 3 03-3 COM 1 

01-4 Input Channel 4 03-4 Relay Output 2 

01-5 Input Channel 5 03-5 COM 2 

01-6 Input Channel 6 03-6 Relay Output 3 

01-7 Input Channel 7 03-7 COM 3 

02-0 Input Channel 8 04-0 Relay Output 4 

02-1 Input Channel 9 04-1 COM 4 

02-2 Input Channel 10 04-2 Relay Output 5 

02-3 Input Channel 11 04-3 COM 5 

02-4 Input Channel 12 04-4 Relay Output 6 

02-5 Input Channel 13 04-5 COM 6 

02-6 Input Channel 14 04-6 Relay Output 7 

02-7 Input Channel 15 04-7 COM 7 

Specifications 

 

Table 15: STXPBS* Specifications 

 

Model STXPB
S032 

STXPB
S132 

STXPB
S232 

STXPB
S332 

STXPB
S432 

STXPB
S532 

STXPB
S016 

STXPB
S116 

STXPB
S824 

STXPB
S924 

STXPB
S825 

STXPB
S925 

Input/Interface Specification 

Number 
of Input 

32 Points   16 Points   16 Points 

Type Positive 
Logic 

Negativ
e Logic 

  Positive 
Logic 

Negativ
e Logic 

  Positive 
Logic 

Negativ
e Logic 

Positive 
Logic 

Negativ
e Logic 

Indicates 1 LED/ 1 point 

Input 

Voltage 

24Vdc 0Vdc   24Vdc 0Vdc   24Vdc 0Vdc 24Vdc 0Vdc 

Maximu
m Off-
State 

 Voltage 

5Vdc   5Vdc   5Vdc 

Minimum 
On-State  

Voltage 

9Vdc   9Vdc   9Vdc 

Input 
Signal 
Delay 

< 0.5msec   < 0.5msec   < 0.5msec 

Input 
Impedan
ce 

About 5.4KΩ   About 5.4KΩ   About 5.4KΩ 

Output Specification 

Number of 
Output 

  32 Points 16 Points       

Type   Negativ
e Logic 

Positive Logic Negativ
e Logic 
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Output 
Load 
Current 

 

  Maximum 0.5A/1pt, 8A/All       

Output 

 Voltage 

  0Vdc 24Vdc 0Vdc       

Drop 

Voltage 
(ON-state) 

  Maximum 0.3Vdc       

Leakage 
Current 
(OFF-
state) 

  Maximum 50uA       

Output 
Signal 
Delay 

  < 0.3msec       

Protection   Short protection, Over Temperature 
protection, Over Current Limit 

      

 

 

 

Model STXPB
S032 

STXPB
S132 

STXPB
S232 

STXPB
S332 

STXPB
S432 

STXPB
S532 

STXPB
S016 

STXPB
S116 

STXPB
S824 

STXPB
S924 

STXPB
S825 

STXPB
S925 

Relay Output Specification 

Number 
of Output 

      16 points 8 points 

Relay 
Type 

      Normally Open, Single Pole, Single Throw 

Output 
Rating 

      2A@5~28.8Vdc,240Vac, 0.8A@48Vdc, 0.5A@110Vac, 

Minimum 
Load 

      100uA, 100mVdc/Point 

Minimum 
On-Stage 
Voltage 
Drop 

      0.5V@2.0A, Resistive Load, 24Vdc 

Output 
Delay 
Time 

      Maximum 10ms 

Initial 
Contact 
Resistan
ce 

      30mΩ 

Expected 
Contact 
Life 

      300K Cycle Resistive, 100K Cycle Inductive 

Common 
Type 

      4 Point 
/1 COM 

1 Point 
/1 COM 

4 Point/1 COM 1 Point/1 COM 

Isolation       Relay Coil/Contact Isolation 

IO Common Specification 
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Power 
Dissipati
on 

Maximum 50mA@24Vdc 

Isolation System Power to internal logic: Non-isolation, Internal logic to I/O driver: Isolation 

Field 
Power 

Supply Voltage: 24Vdc nominal, Supply Voltage range: 11~28.8Vdc 

Field 
Power 
Current 

Maximum 6A@24Vdc 

Weight Maximum 340g 

Module 
Size 

83mm x 99mm x 70mm 

Environm
ent 
Condition 

See “Environmental Specifications" in Appendix A. 
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LED Indicators 

Module Status LED (MOD)  

 

Table 16: Module Status LED 

Color  Status Function 

Off No Power No power is supplied to the unit. 

Green 
Device Operational 

The unit is operating in normal 
condition. 

Flashing Green 
Device in Standby 

The device needs commissioning 
due to configuration missing, 
incomplete or incorrect. 

Flashing Red Minor Fault Recoverable Fault 

Red 

Unrecoverable Fault 

An unrecoverable fault has occurred 

in self-testing: 

 Invalid Module ID 

 Firmware fault 

 Hardware fault 

Network Status LED (NET)  

 

Table 17: Network Status LED 

Color  Status Function 

Off 
Not Powered,  

Not On-line 

Device is not on-line or may not be 
powered 

Flashing Green 
On-line, 

Not connected 

Device is on-line but has no 
connections in the established state 

 Not allocated to a master 

Green 
On-line, 

Connected 

Device is on-line and allocated to a 
master. 

Flashing Red Connection Time-out 
One or more I/O connections are in 
the time-out state. 

Red 

Critical 
Communication 

Failure 

Failed communication. 
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IO Module Status LED (I/O)  

 

Table 18: IO Module Status LED 

Color  Status Function 

Off 
Not Powered 

No IO Module 

Device has no IO module or may not 

be powered 

Flashing Green 
RSTi bus On-line, 

 

RSTi bus is on-line but does not 

exchange I/O data. 

 Valid IO module 
configuration. 

Green 
RSTi bus Connection 

 

IO module is connected and run 

exchanging I/O data 

Flashing Red RSTi bus connection fault   

One or more IO module occurred in 

fault state. 

 Changed IO module 
configuration. 

 RSTi bus communication 
failure. 

Red 
IO Module Configuration 

Failed 

Failed to initialize IO module 

 Detected invalid IO module 
ID. 

 Overflowed Input/Output 
Size 

 Too many IO module 

 Initial protocol failure 

 Mismatch vendor code 
between adapter and IO 
module. 

 

Field Power Status LED 

 

Table 19: STXPBS001: Field Power Status LED 

Color  Status Function 

Off Not Supplied Field Power Not supplied 24V dc field power 

Green Supplied Field Power Supplied 24V dc field power 
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PROFIBUS Module Installation 

Dimensions 

STXPBS001 Dimension 

The following screenshot displays the dimension for STXPBS001. 

 

 
Figure 14: Dimension for STXPBS001 

STXPBS* Dimension 

The following screenshot displays the dimension for STXPBS*. 

 

 

 
Figure 15: Dimension for STXPBS* 
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Mechanical Set Up 

This section describes the mechanical set up for RSTi family. 

Total Expansion 

The number of the module assembly that can be connected is 32 for STXPBS001 and 8 

for STXPBS*. So the maximum length is 426mmm and 179mm respectively. (These 

maximum length figures are considering all single wide modules. These values need to be 

adjusted if double wide modules like ST-2748 are considered) 

Plugging and Removing the Components 

 

Caution 

Before work is done on the components, the voltage supply must be turned off.  

 

As the figure below indicates, in order to safeguard the RSTi module from jamming, it 

should be fixed onto the DIN rail with locking level. 

 

 
Figure 16: Installing module on DIN rail 

Use a small-bladed screwdriver to lift down Locker. Install the Module on Din rail firmly. 

Lift up locker to lock.  
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To remove the modules, unfold the locking lever as shown below. 

 

 
Figure 17: Removing RSTi module from DIN rail 

Internal RSTi bus/Field Power Contacts 

Communication between the RSTi network adapter and the IO module as well as 

system/field power supply of the bus modules is carried out by means of the internal bus. 

It is comprised of 6 data pin and 2 field power pin. 

 

 
Figure 18: Internal RSTi bus 

 

Caution 



Chapter 
 

GFK-2746 Chapter Chapter 
1  Introduction Chapter 
1-27 

1     

Do not touch data and field power pins, in order to avoid soiling and damage by 

ESD noise. 

RSTi bus Specification 

RSTi bus System 

The following screenshot displays the RSTi bus system for STXPBS001. 
 

 
 

Figure 19: RSTi bus System for STXPBS001 
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The following screenshot displays the RSTi bus system for STXPBS*. 
 

 
 

Figure 20: RSTi bus System for STXPBS* 

 

■ Network Adapter Module: The Network Adapter Module forms the link between the 

field bus and the field devices with the IO Modules. The connection to different field 

bus systems can be established by each of the corresponding Network Adapter 

Module, for example, for SyncNet, PROFIBUS, CANopen, DeviceNet, Ethernet/IP, 

CC-Link, MODBUS/Serial, MODBUS/TCP etc. 

■ IO Module: The IO Modules are supported by a variety of input and output field 

devices. There are digital and analog input/output modules and special function 

modules. 

■ Two types of RSTi bus Message: 

 Service Messaging 

 I/O Messaging 
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RSTi bus Pin Description  

 

Table 20: RSTi bus Pin and Description 

No.  Name Description 

1.  Vcc System supply voltage (5Vdc) 

2.  GND System Ground 

3.  Token Output Token output port of Processor module 

4.  Serial Output Transmitter output port of Processor module 

5.  Serial Input Receiver input port of Processor module 

6.  Reserved Reserved for bypass Token 

7.  Field GND Field Ground 

8.  Field Vcc Field supply voltage (24Vdc) 

PROFIBUS Communication Interface 

PROFIBUS Communication Interface  

 

 

 
Figure 21: PROFIBUS Adapter Communication interface 

 
The following table describes the Signal Name and Description. 
 

Table 21: Signal name and Description 

No.  Name Description 

1.  FG  

2.  -  

3.  RXD/TXD-P Receive/Transmit data-plus (B wire) 

4.  CNTR-P 
Repeater control signal (direction control), RTS 
signal 

5.  DGND Data ground (reference potential for VP) 

6.  VP Supply voltage-Plus (P5V) 
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7.  -  

8.  RXD/TXD-N Receive/Transmit data-minus (A-wire) 

9.  CNTR-N Repeater Control Signal (direction control) 

 

All FieldBus devices which use a standard 9-pin Sub-D connector should provide the VP 

and DGND signals on the bus connector in addition to receive and transmit signals. With 

all other connector types, only receive and transmit signals need to be connected.  

 

Make sure that the connector type used is suitable for the selected baud rate. 

If optional signals are provided, they must also comply with EN50170 Volume 2 and they 

must be correctly described in the respective GSD file. 

 

To prevent EMC interface from entering the device, the cable shield should be connected 

to the functional ground of the device (generally the electrically conductive case). This is 

done by connecting the cable shield to the metal case of the Sub-D connector and the 

functional ground over a larger area. The bus connector must have a low-impedance 

connection to the cable shield. 

The data transfer technology of the serial bus system, which uses a shielded twisted pair 

data cable, is described in the specification of the interface-immune RS 485 interface 

standard. To allow correct bus termination, each station must connect the signals DGND 

and VP (5V) to pins 5 and 6 of the connector respectively. The 5V supply for the 

terminating resistors (VP) should have a minimum current rating of 10mA (the current load 

can increase to 12mA if a NULL signal is sent through the bus). The current rating should 

be increased to approximately 90mA if you need to supply other types of devices on the 

bus such as bus terminals and optical fiber cable drivers. Due to the capacitive load of the 

station and the resulting cable reflections, bus connectors should be provided with built-in 

series inductors. 

 

Caution 

The use of an incorrect supply voltage or frequency can cause severe damage to 

the component. 
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Choice of PROFIBUS data transfer cable type 

■ Depending on the application, the user can choose between electrical and optical fiber 

data transfer cables. The following types of electrical data cables can be used: 

 Standard bus cable 

 Standard bus cable with halogen-free sheath (type FRNC) 

 Cable with PE Sheath for use in the food and manufacturing industries. (It differs 

from the standard bus cable solely in the cable sheath). 

 Direct buried cable with additional protective sheath for lying in the ground. 

 Trailing cable: This is a special cable type which is used where parts of the 

machine move occasionally or continuously. 

 Festooned cable: Compared to a trailing cable, a festooned cable has an 

additional strain relief element. 

■ The bus cable is specified in EN 50170 part 8-2 as "Cable Type A", and should 

comply with the parameters in the following table. Cable Type B, which is also 

described in EN 50170, is outdated and should no longer be used. 

■ Parameters for standard type A bus cables: 

 

Table 22: Parameters for Standard Type A Bus Cables 

Parameter Cable Type A 

Characteristic impedance in Ω 135..165 at a frequency of (3..20MHz) 

Operating capacity(pF/m) < 30 

Loop resistance (Ω/km ) <=110 

Core diameter (mm) >0.64* 

Cora cross-section (mm) >0.34* 

* The cable cross-sections used should be compatible with the mechanical 

specifications of the bus interface connector. 

 

The cable parameters specified for standard Type A bus cables result in the maximum 
length of each bus segment for the respective data transfer rate as shown in the below 
table. 
 

■ Maximum Cable Lengths per Segments 

 

Table 23: Maximum Cable Lengths per Segments 

Baudrate 9.6 19.2 45.45 93.75 187.5 500 1500 3000 6000 12000 

Maximum 
segment 

Length in 
‘m’(m) 

1200 1200 1200 1200 1000 400 200 100 100 100 

 

Note: In a PROFIBUS-DP/FMS installation, you must choose a data transfer rate which 
is supported by all devices connected to the bus. The chosen data transfer rate 
then determines the maximum segment lengths as shown above. 
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The maximum admissible distance between two bus stations in each PROFIBUS network 
can be calculated as follows: 
 
(NO_REP+1)*Segment length,  
Where NO_REP =The maximum number of repeaters connected in series (depends on 
repeater type). 
 
Example: The repeater manufacture specifications allow nine repeaters to be connected 
in series. The maximum distance between two bus stations at a data transfer rate of 1500 
kbit/s is then as follow:  
(9+1)*200m=2000 m 
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PROFIBUS Module Configuration 

DIP Switch Setting 

 

 

 

 

* Station No. Setting 

example 

 

When setting Station 

Number to 20, 3 and 5, Dip 

S/W On. 

 

* Directions for setting Node Number (Station No) 

1. Select address  ithin the range of 00 to     (Station no. 00      

2. Station number setting out of the range will cause communication 

error. 

3. Duplicating Station No. will cause communication error. 

 

DIP Setting Switch 

 

 

 

 
 

Station Number setting Switch 

 

 

 

 

 

 

 

 

 Station 

Address 

 Quick Start 

Mode 

 

64 32 16 8 4 2 1 

Relevant Value 

        
1 2 3 4 5 6 7 

        
1 2 3 4 5 6 7 

 * Dip No.8 Mode Setting: 

 Off: Normal 
Booting    

 On: Quick 
Booting  



Chapter 
 

 

Chapter 
1-34 RSTi Network Adapter Manual  User Manual - January 2012 GFK-2746 

1     

 Wiring of Communication and Power Cable and Installation of the Modules 

PROFIBUS Connection cable wiring and Installation 

 

 

 

Using a small-bladed screwdriver, release the DIN rail locking clip by pulling clip 
downward. The clip will click and lock into the open position.  Install the module on the 
DIN rail firmly. Once module is in place on the DIN rail, push the clip upward to secure the 
module on the DIN rail.  To remove, pull clip downward until the locking clip clicks and 
locks, the module can now be removed from the DIN rail. 

Note: Make sure that the locking clip is in the upward position to ensure the module is 
properly grounded and secured to the DIN rail. 
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System and Field Power cable wiring 

 

 

Directions for PROFIBUS connection for field bus network interface power & ST I/O field 
power wiring. 
 

1. For safety, supply system power and field power should be separated. 

 System  Power:  for System & PROFIBUS communications   

 Field Power: for I/O field device connections 
2. Make sure power supplies for system power and field power are supplied 

separately. 
3. Use PROFIBUS certified cables only. 
4. Do not insert any other devices or components (such as transistor) into 

PROFIBUS field bus besides PROFIBUS qualified products. 

Station Number Setting S/W 
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1. Set station number within the specified range (00 ~ 99). 

2. Note that if the station number is once set and an attempt is made to change the 

station number, it would result in communication errors. Power cycle the module 

and download the new assigned station number to restore communication. 

Configuring an I/O Station for PROFIBUS Communication 

To configure I/O station, add a GE-IP PROFIBUS master module at the desired slot in the 

Rx3i or 90-30 Proficy Machine Edition project. Ensure that you have the latest GSD file 

imported. Right click on the master module and choose “Add Slave”. Select “STXPBS001” 

for PROFIBUS Network Adapter or STXPBS for all-in-one PROFIBUS Network Adapter. 

Select “OK”. 

 

 

A pop-up menu will appear which can help you in configuring the I/O station along with the 

I/O modules. 

1. Assign a name, description and station address for the I/O station. 

2. Select the Modules tab and add the desired I/O modules as per the application. 

Ensure that the first module is always STXPBS001 or STXPBS* (in case you have 

selected net ork adapter as STXPBS  at position”0”. 

At least one I/O module must be configured for successful PROFIBUS 

communication. 

3. Go to the Parameters tab and select the parameters according to the application. 

The Parameters tab is as shown below: 
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Five parameters can be configured as follows: 

1. Watchdog time base: The watchdog timer can be used for detection of a network 

fault. If the Network Adapter detects a network error within the watchdog time, 

STXPBS001 will control slots depending on the values in DP Clear Action. 

Options are 10ms and 1ms. 

2. Word Data Format: The options are MOTOROLA & INTEL. 

MOTOROLA (big endian): The Swap Bytes parameter must be set to False for the 

IO modules connected to the node. 

INTEL (little endian): The Swap Bytes parameter must be set to true for the IO 

modules connected to the node. 

3. DP Clear Action: If a network fault is detected within the specified watchdog time 

base, the outputs of an I/O station will acquire values as per the options specified 

in DP clear action. The options are: 

a. Bus Stop (I/O Fault action): The communication between STXPBS001 

and modules will be stopped and each module will control its IO Data 

according to the Fault Action selected for it. The Bus status will be ready 

(IO status LED will blink). To configure the I/O module for fault action, go 

to the Modules tab and select Properties. The example below uses an 

ST-4522 module. Note that substitute value low or high denotes low or 

high byte values. 

 

b. Bus Run (Clear output): The communication between STXPBS001 and 

modules will run. All the modules’ outputs will be set to 0. The IO status 

LED will be green. 

c. Bus Run (Hold output): The communication between STXPBS001 and 

modules will run. All module outputs will hold the last value but bus will 

run. The IO status LED will be green. 

4. Reaction to Bus Fault: If Bus error is detected, the behavior of the network 

module  ill be as per the options selected belo . It should be noted that “Restart 

to Bus Fault” should be set to “Po er restart” for this parameter to behave 

appropriately. Note that in order to observe a “loss of Device” in IO fault table , the 

“slave status Fault table entries” must be set to “true” in the GE IP Profibus master 

settings tab as shown below: 
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a. Profibus Communication: Last input values will not hold. NET LED will be 

blinking Green. Network adaptor communication with master stops. IO 

LED  ill be red and fault “Loss of device' logged in I/O fault table.  

b. Clear Input Data: Input values will be zero. NET LED will be Green. 

Network adaptor communication with master intact. IO LED will be red 

and fault “Loss of device' logged in I/O fault table. 

c. Stay with last Input data: Input values will be holding. NET LED will be 

Green. Network adaptor communication with master intact. IO LED will be 

red and fault “Loss of device' logged in I/O fault table. 

5. Restart on Bus Fault: If Bus error is detected, the network module will power up 

depending upon the options selected for this parameter. The options are “Po er 

restart” & “Auto restart”. 

 

It should be noted that only (1. Watch dog time base) and (4. Reaction to Bus Fault) are 

applicable for STXPBS (Network adapter with Integrated IO modules). 

Apart from these settings, for Analog output modules, serial modules, digital output 

modules etc., select the module at the “modules” tab and choose properties for additional 

settings. Refer to individual module description for more details. 

 

Note: Refer to the examples section in the Power Modules chapter in New Slice IO 

manual for more details about the IO node configuration using the different power 

modules.  
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The Profibus network module also supports DPV1 service. The details are as below: 

DPV1 Write service 

 Slot#=0, Index 1: Write STXPBS001 extension parameter(2Byte) 

 Slot#0~31, Index 1: Write parameter for an IO module. 

 Slot#0~31, Index 2: Write memory data to an IO module. 

 Slot#= 254: Write user data to EEPROM user area 

Index=0~127(Offset in EEPROM user area) 

Data Ln=Length for data to be written 

Data [0] ~Data[n] =User data 

 

List of valid commands for (Slot#=0, Index 1: Write STXPBS001 extension parameter (2 

bytes). Note that the length of parameter may vary depending upon the module chosen for 

STXPBS* Network adapter with Integrated IO modules and hence the command word. 

 

Command Reaction to 
Bus Fault 

DP Clear Action Word data 
Format 

Restart on Bus 
fault Hex Binary 

00 00 00000000 
00000000 

00: Profibus 
communication 

00: Bus Stop IO 
fault action 00:INTEL 00:Power reset 

00 10 
00000000 
00010000 

00: Profibus 
communication 

00: Bus Stop IO 
fault action 00:INTEL 01: auto reset 

01 00 
00000001 
00000000 

00: Profibus 
communication 

00: Bus Stop IO 
fault action 01:MOTOROLA 00:Power reset 

01 10 
00000001 
00010000 

00: Profibus 
communication 

00: Bus Stop IO 
fault action 01:MOTOROLA 01: auto reset 

00 04 
00000000 
00000100 

00: Profibus 
communication 

01: Bus Run ( 
clear Output) 00:INTEL 00:Power reset 

00 14 
00000000 
00010100 

00: Profibus 
communication 

01: Bus Run ( 
clear Output) 00:INTEL 01: auto reset 

01 04 
00000001 
00000100 

00: Profibus 
communication 

01: Bus Run ( 
clear Output) 01:MOTOROLA 00:Power reset 

01 14 
00000001 
00010100 

00: Profibus 
communication 

01: Bus Run ( 
clear Output) 01:MOTOROLA 01: auto reset 

00 08 
00000000 
00001000 

00: Profibus 
communication 

10:  Bus Run ( 
Hold Output) 00:INTEL 00:Power reset 

00 18 
00000000 
00011000 

00: Profibus 
communication 

10:  Bus Run ( 
Hold Output) 00:INTEL 01: auto reset 

01 08 
00000001 
00001000 

00: Profibus 
communication 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 00:Power reset 

01 18 
00000001 
00011000 

00: Profibus 
communication 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 01: auto reset 

00 01 
00000000 
00000001 

01: Clear Input 
data 

00: Bus Stop IO 
fault action 00:INTEL 00:Power reset 

00 11 
00000000 
00010001 

01: Clear Input 
data 

00: Bus Stop IO 
fault action 00:INTEL 01: auto reset 

01 01 
00000001 
00000001 

01: Clear Input 
data 

00: Bus Stop IO 
fault action 01:MOTOROLA 00:Power reset 
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Command Reaction to 
Bus Fault 

DP Clear Action Word data 
Format 

Restart on Bus 
fault Hex Binary 

01 11 
00000001 
00010001 

01: Clear Input 
data 

00: Bus Stop IO 
fault action 01:MOTOROLA 01: auto reset 

00 05 
00000000 
00000101 

01: Clear Input 
data 

01: Bus Run ( 
clear Output) 00:INTEL 00:Power reset 

00 15 
00000000 
00010101 

01: Clear Input 
data 

01: Bus Run ( 
clear Output) 00:INTEL 01: auto reset 

01 05 
00000001 
00000101 

01: Clear Input 
data 

01: Bus Run ( 
clear Output) 01:MOTOROLA 00:Power reset 

01 15 
00000001 
00010101 

01: Clear Input 
data 

01: Bus Run ( 
clear Output) 01:MOTOROLA 01: auto reset 

00 09 
00000000 
00001001 

01: Clear Input 
data 

10:  Bus Run ( 
Hold Output) 00:INTEL 00:Power reset 

00 19 
00000000 
00011001 

01: Clear Input 
data 

10:  Bus Run ( 
Hold Output) 00:INTEL 01: auto reset 

01 09 
00000001 
00001001 

01: Clear Input 
data 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 00:Power reset 

01 19 
00000001 
00011001 

01: Clear Input 
data 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 01: auto reset 

00 02 
00000000 
00000010 

10: Stay with last 
input 

00: Bus Stop IO 
fault action 00:INTEL 00:Power reset 

00 12 
00000000 
00010010 

10: Stay with last 
input 

00: Bus Stop IO 
fault action 00:INTEL 01: auto reset 

01 02 
00000001 
00000010 

10: Stay with last 
input 

00: Bus Stop IO 
fault action 01:MOTOROLA 00:Power reset 

01 12 
00000001 
00010010 

10: Stay with last 
input 

00: Bus Stop IO 
fault action 01:MOTOROLA 01: auto reset 

00 06 
00000000 
00000110 

10: Stay with last 
input 

01: Bus Run ( 
clear Output) 00:INTEL 00:Power reset 

00 16 
00000000 
00010110 

10: Stay with last 
input 

01: Bus Run ( 
clear Output) 00:INTEL 01: auto reset 

01 06 
00000001 
00000110 

10: Stay with last 
input 

01: Bus Run ( 
clear Output) 01:MOTOROLA 00:Power reset 

01 16 
00000001 
00010110 

10: Stay with last 
input 

01: Bus Run ( 
clear Output) 01:MOTOROLA 01: auto reset 

00 0A 
00000000 
00001010 

10: Stay with last 
input 

10:  Bus Run ( 
Hold Output) 00:INTEL 00:Power reset 

00 1A 
00000000 
00011010 

10: Stay with last 
input 

10:  Bus Run ( 
Hold Output) 00:INTEL 01: auto reset 

01 0A 
00000001 
00001010 

10: Stay with last 
input 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 00:Power reset 

01 1A 
00000001 
00011010 

10: Stay with last 
input 

10:  Bus Run ( 
Hold Output) 01:MOTOROLA 01: auto reset 

DPV1 Read service 

 Slot#=0, Index 1: Read STXPBS001 extension parameters (2Byte) 

 Slot#1~32, Index 1: Read parameter for an IO module. 

 Slot#1~32, Index 2: Read memory data from an IO module. 

 Slot#=0, Index 254: Read vendor code from EEPROM directly. 
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 Data Ln=1(Fixed) 

Slot#=0, Index 253: read FW revision 

Data Ln=4(Fixed for STXPBS001), 1(all-in-one modules) 

 Slot#=254: read user data from EEPROM user area 

Index=0~127(Offset in EEPROM user area) 

Data Ln=Length for data to be read. 

Terminator Resistor 
The following screenshot displays the terminator resistor specification. 
 

 
Figure 22: Terminator Resistor Specification 

 
In order to minimize cable reflections and ensure a defined noise level on the data lines, 
the data transfer cable must be terminated at both ends with a terminating resister 
combination as follows: 
 

 
 

Figure 23: Terminating Resistor Combination 
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Station Address and Quick Startup Mode Setup 

Station Address Setup for STXPBS001 

Each PROFIBUS Adapter must have a unique address (from 1 to 99) so that it can be 
addressed independently from other nodes. The address 0 is reserved to identify a 
broadcast exchange. No response is returned to broadcast requests sent by the master. 
 

 
Figure 24: MAC ID of a slave node 

 
 

The above figure shows MAC ID 27(=2*10 + 7*1) of a slave node. 
 

■ Communication Speed Setting 

 Refer to GEIP PROFIBUS master module settings to change the communication 

speed. 

 

Caution 

MAC ID addresses have to be unique throughout the entire interconnected 

networks. 
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Station Address Setup for STXPBS* 
Each PROFIBUS Adapter must have a unique Node Station address (from 0 to 99) so that 
it can be addressed independently from other nodes. 
 
The below screenshot shows Dip Switch #1~7 setting. 
 

 
Figure 25: DIP Switch  

 

■ Node Station Address Setting Example 

In order to change station ID to No. 20 (Bin 10100), Dip switch No.3 and 5 must be ON 
and others must be OFF. 

 

Figure 26: Node Station Address Setting  

 

■ Mode Setting 

Table 24: Mode Setting 

 

Dip #8.  Start Mode 

OFF Normal Booting 

ON Quick Booting 

Note: Directions for setting Node Number (Station number) 

1. Please set it within the range of contactable Station number (Station no. 00~99). 
2. Station number setting out of the range will cause Communication Error. 
3. When double setting Station Number, communication error will occur. 
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I/O Process Image Map 
An IO module may have three types of data: I/O data, configuration parameter, and 
memory register. The data exchange between network adapter and IO modules is done 
by means of an I/O process by RSTi bus protocol.  
 
The following screenshot shows the data flow between network adapter and IO modules 
for STXPBS001. 
 

 
Figure 27: STXPBS001: Data flow between Network Adapter and IO Modules 

 

The following screenshot shows the data flow of process image between network adapter 
and IO modules for STXPBS*. 
 

 
Figure 28: STXPBS*: Data flow between Network Adapter and IO Modules 
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GSD and I/O Module Setting 

GSD (Electronic data sheet of a device) files contain and describe the functions and 

characteristics of PROFIBUS devices. The abbreviation GSD means Generic Station 

Description (Device Base Files). All the available GSD files together form the device 

database. 

When Proficy machine edition/ configuration tool is started, the system configurator 

automatically retrieves all the GSD files stored in the GSD directory. 

The device names are placed into an internal list. During the configuration, the device-

specific data is retrieved directly from the GSD files. 

If a DP Slave device does not appear in the selection list, a corresponding GSD file can 

be added as shown below:  

Right click on the GEIP profibus master and choose “add slave”, a pop up  indo   ill 

open showing the available slave modules. 

 

 
Figure 29: Adding slave modules  

Choose the desired slave device or choose “Have Disk” to add other slave devices. No  

click on “Toolchest”, choose “Profibus Devices”, select the desired net ork adapter and 

hit F1 to see the contents of the GSD file. For latest GSD file, please visit GE-IP support 

site. 
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Figure 30: Contents of GSD file  

Example 

Example of Output Process Image (Output Register) Map for STXPBS001 

■ For example: Slot configuration 

 

 
Figure 31: Slot Configuration  

 

The following table lists the slot number and the module description for that slot. 

 

Table 25: Slot number and Module Description 

Slot Address Module Description 

#0 PROFIBUS Adapter 

#1 4-discrete output 

#2 4-discrete output 

#3 8-discrete output 

#4 2-analog output 

#5 16-discrete output 

#6 4-discrete output 

#7 8-discrete output 

#8 2-relay output 

#9 2-relay output 

#10 2-analog output 

#11 16-discrete output 
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■ Output Process Image Mode#0 (Uncompressed Input Processing Data), default 

output image 

 

Table 26: Output Process Image Mode 

Byte Slot # Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

Write Byte 0 Slot 1 Not used Discrete Output 4 points 

Write Byte 1 Slot 2 Discrete Output 8 points 

Write Byte 2 Slot 3 Analog Output Ch0 low byte 

Write Byte 3 Analog Output Ch0 high byte 

Write Byte 4 Analog Output Ch1 low byte 

Write Byte 5 Analog Output Ch1 high byte 

Write Byte 6 Slot 4 Discrete Output low 8 points 

Write Byte 7  Discrete Output high 8 points 

Write Byte 8 Slot 5 Not used Discrete Output 4 points 

Write Byte 9 Slot 6 Discrete Input 8 points 

Write Byte 10 Slot 7 Not used Discrete Output 2 points 

Write Byte 11 Slot 8 Not used Discrete Output 2 points 

Write Byte 12 Slot 9 Analog Output Ch0 low byte 

Write Byte 13 Analog Output Ch0 high byte 

Write Byte 14 Analog Output Ch1 low byte 

Write Byte 15 Analog Output Ch1 high byte 

Write Byte 16 Slot 10 Discrete Output low 8 points 

Write Byte 17 Discrete Output high 8 points 

Write Byte 18 Slot 11 Reserved Discrete Output 4 points 

 

 
 

Figure 32: Output Process Image Mode 
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Example of parameter assign 

■ For example: Slot configuration 

 

 
Figure 33: Slot Configuration  

 

The following table lists the slot number, module description, and parameter size. 

 

Table 27: Slot number and Module Description 

Slot Address Module Description Parameter Size 

#0 STXPBS001 2 Byte 

#1 ST-2314 (4-discrete output) 2 Byte 

#2 ST-2318 (8-discrete output) 2 Byte 

#3 ST-4112 (2-analog output) 6 Byte 

#4 ST-1314 (4-discrete input) 0 Byte 

#5 ST-3702 (2-RTD input) 2 Byte 

#6 ST-221F (16-discrete output) 4 Byte 
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■ Parameter 

 

Table 28: Parameter Description 

Byte offset Slot # Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

Byte 0  

PROFIBUS-DP Standard Parameter 

Byte 1 

Byte 2 

Byte 3 

Byte 4 

Byte 5 

Byte 6 

Byte 7  

PROFIBUS-DPV1 Parameter Byte 8 

Byte 9 

Byte 10 Slot 0 
STXPBS001 User Parameter 

Byte 11 

Byte 12 Slot 1 
ST2314 Parameter 

Byte 13 

Byte 14 Slot 2 
ST2318 Parameter 

Byte 15 

Byte 16 Slot 3 

ST4112 Parameter 

Byte 17 

Byte 18 

Byte 19 

Byte 20 

Byte 21 

Byte 22 Slot 5 
ST3702 Parameter 

Byte 23 

Byte 24 Slot 6 

ST221F Parameter 
Byte 25 

Byte 26 

Byte 27 

 

Note: The "STXPBS001 User Parameter" size is 5 bytes instead of 2 Bytes. 
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Example of Input Process Image Map for STXPBS* 

Input image data depends on slot position and IO Module data type. 

■ For example: Slot configuration 

 

 
Figure 34: Slot Configuration  

 

The following table lists the slot number and module description. 

 

Table 29: Slot number and Module Description 

Slot Address Module Description 

#0 STXPBS032 

32-discrete input (4byte) 

#1 4-discrete Input (4 bit)  

#2 16-discrete Input (2 byte) 

#3 4-analog Input (4 word) 

#4 2-analog output (2 word) 
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■ Input Process Image Mode#0 (Uncompressed Input Processing Data) 

 

Table 30: Input Process Image Mode 

Byte Slot # Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

Byte 0 0 (AT2) 

 

1st input byte (Base IO) 

Byte 1 2nd input byte (Base IO) 

Byte 2 3rd input byte (Base IO) 

Byte 3 4th input byte (Base IO)  

Byte 4 1 Empty, Always 0 Discrete Input 4 points (Slot# 1) 

Byte 5 2 Discrete Input low 8 pts (Slot#2) 

Byte 6 Discrete Input high 8 pts (Slot#2) 

Byte 7 3 Analog Input Ch0 low byte (Slot#3) 

Byte 8 Analog Input Ch0 high byte (Slot#3) 

Byte 9 Analog Input Ch1 low byte (Slot#3) 

Byte 10 Analog Input Ch1 high byte (Slot#3) 

Byte 11 Analog Input Ch2 low byte (Slot#3) 

Byte 12 Analog Input Ch2 high byte (Slot#3) 

Byte 13 Analog Input Ch3 low byte (Slot#3) 

Byte 14 Analog Input Ch3 high byte (Slot#3) 
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Example of Output Process Image Map for STXPBS* 

■ For example: Slot configuration 

 

 
Figure 35: Slot Configuration  

The following table lists the slot number and module description. 

 

Table 31: Slot number and Module Description 

Slot Address Module Description 

#0 STXPBS032 

32-discrete input (4 byte) 

#1 2-discrete Input (2 bit)  

#2 4-discrete Input (4 bit) 

#3 16-discrete output (2 byte) 

#4 2-analog output (2 word) 
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■ Output Process Image Mode#0 (Uncompressed Output Processing Data) 

 

Table 32: Output Process Image Mode 

Byte Slot # Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

Byte 0 0 (AT2) 

 

1st output byte (Base IO) 

Byte 1 2nd output byte (Base IO) 

Byte 2 3rd output byte (Base IO) 

Byte 3 4th output byte (Base IO)  

Byte 4 1 
Empty, Don’t care 

Discrete Output 2 
points (Slot# 1) 

Byte 5 2 Empty, Don’t care Discrete Output 4 points (Slot#2) 

Byte 6 3 Discrete Output low 8 pts (Slot#3) 

Byte 7 Discrete Output high 8 pts (Slot#3) 

Byte 8 4 Analog Output Ch0 low byte (Slot#4) 

Byte 9 Analog Output Ch0 high byte (Slot#4) 

Byte 10 Analog Output Ch1 low byte (Slot#4) 

Byte 11 Analog Output Ch1 high byte (Slot#4) 
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STXPBS001: DPV1 Service Specification 

Supported Service 

■ MSAC1 Read 

■ MSAC1 Write 

■ MSAC2 Initiate / MSAC2 Abort 

■ MSAC2 Read 

■ MSAC2 Write 

MSAC1 Read (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC1 Read Request 

Parameter Description 

Remote Address Slave Address (0~99) 

Slot Number 
Slot Number (0~32),             

0 : STXPBS001 

Index 

1 : Parameter 

2 : Memory 

... 

252: IO Module Vendor code (Not used by user) 

253: Revision (Not used by user) 

254: Vendor code (Not used by user) 

Length 1~128 

 

■ MSAC1 Read Confirm (+) 

Parameter Description 

Remote Address Slave Address (0~99) 

Length 1~128 

Data User Data 

 

■ MSAC1 Read Confirm (-) 

Parameter Description 

Remote Address Slave Address (0~99) 

Error Decode - 

Error code 1 - 

Error code 2 Reserved 
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MSAC1 Write (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC1 Write Request 

Parameter Description 

Remote Address Slave Address (0~99) 

Slot Number 
Slot Number (0~32), 

0: STXPBS001 

Index 

1: Parameter 

2: Memory 

 

Length 1~128 

Data 

1. Parameter 

2. Memory 

■ Data[0]: Offset Low 

■ Data[1]: Offset High 

■ Data[2]…: User Data 

3. Revision(Not used by user) 

■ Data[0]: 0xAE 

■ Data[1]: 0xBE 

■ Data[2]: 0xCE 

■ Data[3]: 0xDE 

■ Data[4]:  

4. Vendor(Not used by user) 

■ Data[0]: 0xAE 

■ Data[1]: 0xBE 

■ Data[2]: 0xCE 

■ Data[3]: 0xDE 

■ Data[4]:  

  

■ MSAC1 Write Confirm (+) 

Parameter Description 

Remote Address Slave Address (0~99) 

Length 1~128 

 

■ MSAC1 Write Confirm (-) 

Parameter Description 

Remote Address Slave Address (0~99) 

Error Decode - 

Error code 1 - 

Error code 2 Reserved 
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MSAC2 Initiate (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC2 Initiate Request 

Parameter Description 

C_Ref PROFIBUS-DP Extensions to EN50170 

Rem_Add Slave station address(0~99) 

Send Timeout PROFIBUS-DP Extensions to EN50170 

Features_Supported_1 0x03 

Features_Supported_2 Reserved 

Profile_Features_Supported_1 PROFIBUS-DP Extensions to EN50170 

Profile_Features_Supported_2 PROFIBUS-DP Extensions to EN50170 

Profile_Ident_Number PROFIBUS-DP Extensions to EN50170 

Add_Addr_Param 
PROFIBUS-DP Extensions to EN50170 

(S-Addr = 0, D-Addr = 0) 

  

■ MSAC2 Initiate Confirm (+) 

Parameter Description 

C_Ref PROFIBUS-DP Extensions to EN50170 

Features_Supported_1 PROFIBUS-DP Extensions to EN50170 

Features_Supported_2 PROFIBUS-DP Extensions to EN50170 

Profile_Features_Supported_1 0 

Profile_Features_Supported_2 0 

Profile_Ident_Number 0 

Add_Addr_Param 
PROFIBUS-DP Extensions to EN50170 

(S-Addr = 0, D-Addr = 0) 

 

■ MSAC2 Initiate Confirm (-) 

Parameter Description 

Remote Address Communication Reference 

Error Decode - 

Error code 1 - 

Error code 2 Reserved 
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MSAC2 Abort (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC2 Initiate Request 

Parameter Description 

C_Ref PROFIBUS-DP Extensions to EN50170 

Subnet Slave station address 

Instance PROFIBUS-DP Extensions to EN50170 

Reason_code 
PROFIBUS-DP Extensions to EN50170 

MSAC2_Read,MSAC2_Write 

MSAC2 Read (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC2 Read Request 

Parameter Description 

C_Ref Communication-Reference 

Slot Number 
Slot Number (0~32), 

0: STXPBS001 

Index 

1: Parameter 

2: Memory 

252: IO Module Vendor code (Not used by user) 

253: Revision (Not used by user) 

254: Vendor code (Not used by user) 

Length 1~128 

 

■ MSAC2 Read Confirm (+) 

Parameter Description 

C_Ref Communication-Reference 

Length 1~128 

Data - 

 

■ MSAC2 Read Confirm (-) 

Parameter Description 

Remote Address Communication-Reference 

Error Decode - 

Error code 1 - 

Error code 2 Reserved 
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MSAC2 Write (PROFIBUS-DP Extensions to EN 50170) 

■ MSAC2 Write Request 

Parameter Description 

Remote Address Slave Address (0~99) 

Slot Number 
Slot Number (0~32), 

0: STXPBS001 

Index 

1: Parameter 

2: Memory 

 

Length 1~128 

Data 

1. Parameter 

2. Memory 

■ Data[0]: Offset Low 

■ Data[1]: Offset High 

■ Data[2]…: User Data 

3. Revision 

■ Data[0]: 0xAE 

■ Data[1]: 0xBE 

■ Data[2]: 0xCE 

■ Data[3]: 0xDE 

■ Data[4]:  

4. Vendor 

■ Data[0]: 0xAE 

■ Data[1]: 0xBE 

■ Data[2]: 0xCE 

■ Data[3]: 0xDE 

■ Data[4]:  

 

■ MSAC2 Write Confirm (+) 

Parameter Description 

Remote Address Communication-Reference 

Length 1~128 

 

■ MSAC2 Write Confirm (-) 

Parameter Description 

Remote Address Communication-Reference 

Error Decode - 

Error code 1 - 

Error code 2 Reserved 
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Error Decode (PROFIBUS-DP Extensions to EN 50170) 

■ 0~127 : Reserved 

■ 128 : DPV1 

■ 129~253 : Reserved 

■ 254 : FMS 

■ 255 : HART 

Error Code_1 (PROFIBUS-DP Extensions to EN 50170) 

Bit  7  6  5  4  3  2  1  0 

 

■ Error Class 

 0xA : Application class 

 

■ Error code 

 0: Read Error 

 1: Write Error 

 2: Module Failure 

 3 ~7: Reserved 

 8: Version conflict 

 9: Feature not supported 

 10~15: User specific 

 

■ Error Class 

 0xB : Access class 

■ Error code 

 0: Invalid index 

 1: Write length error 

 2: Invalid slot 

 3: Type conflict 

 4: Invalid area 

 5: state conflict 

 6: access denied 

 7: invalid range 

 8: invalid parameter 

 9: invalid type 

 10~15: User specific 

 

■ Error Class 

 0xC : Resource class 

■ Error code 

 0: read constrain conflict 

 1: Write constrain conflict 

 2: Resource busy 

 3  Resource unavailable 

 4 ~7: Reserved 

 8~15: User specific 
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■ Error Class 

 0xD : STXPBS001 Specific 

Class 

■ Error code 

 1: Slot Parameter write 

error 

 2: Read memory error 

 3: Write memory error 

 

Diagnostics 

Byte Item Description 

0 Station status 0 PROFIBUS Standard 

Diagnostic 1 Station status 0 

2 Station status 0 

3 Master Address 

4 PNO Ident Number High 

5 PNO Ident Number Low 

6 ID Diagnostic Header Extended Diagnostic 

(ID Related Diagnostic) 7 Diagnostic allocation (Slot0~7) 

8 Diagnostic allocation (Slot8~15) 

9 Diagnostic allocation (Slot16~23) 

10 Diagnostic allocation (Slot24~31) 

11 Diagnostic allocation (Slot32~39) 

12 Reserved 

13 

14 

15 Device Status Diagnostic Header Extended Diagnostic 

(Device Status) 16 Status Type (0xA0:Manufacture-specific) 

17 Slot Number 

18 Status differentiation (0:No differentiation) 

19 Status message 

20 Reserved 

 

■ ID Related Diagnostic 

Byte  Bit 7  Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

6 ID Diagnostic Header (0x45) 

7 Slot 7 Slot 6 Slot 5 Slot 4 Slot 3 Slot 2 Slot 1 
STXPB
S001 

8 Slot 15 Slot 14 Slot 13 Slot 12 Slot 11 Slot 10 Slot 9 Slot 8 

9 Slot 23 Slot 22 Slot 21 Slot 20 Slot 19 Slot 18 Slot 17 Slot 16 

10 Slot 31 Slot 30 Slot 29 Slot 28 Slot 27 Slot 26 Slot 25 Slot 24 

11 Reserved Slot 32 
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■ Device Related Diagnostic (Status message byte) 

 0x21: No response from expansion slot 

 0x22: Response error (Type) 

 0x23: Response error (Slot Number) 

 0x24: Response error (Length) 

 0x25: Response error (Protocol) 

 0x26: Response error (ID) 

 0x27: Response error (Function code) 

 0x28: Response error (CRC) 

 0x29: Response error (Data) 

 0x2A: Response error (Sequence) 

 0x2B: STXPBS001 Request error 

 0x2C: STXPBS001 Broadcasting error 

 0x41: RSTi bus Rx Timeout 

 0x42: Faulty input data (Type) 

 0x43: Faulty input data (Slot number) 

 0x44: Faulty input data (Length) 

 0x45: Faulty input data (CRC) 

 0x46: Faulty input data (Slot diag.) 

 0x47: Input update timeout 

 0x48: RSTi bus token fault 

 0xC1: Resource error of slot 

 0xC2: Not supported service from slot 

 0xC3: Attribute error from slot 

 0xC4: Slot is already in this mode 

 0xC5: Object conflict from slot 

 0xC6: Attribute not settable 

 0xC7: Insufficient data 

 0xC8: Not supported attribute 

 0xC9: Too much data 

 0xCA: Object not exist 

 0xCB: Invalid slot parameter 

 0xCC: Store fail 

 0xCD: Access denied 

 0xCE: RSTi bus token error 

 0xCF: Object not exist 

 0xD0: Slot memory size over 

 0xE1: No expansion slot 

 0xE2: Too many slots 

 0xE3: Input data size overflow 
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 0xE4: Output data size overflow 

 0xE5: Invalid product code 

 0xE6: Set output-offset error 

 0xE7: Set slot active-flag error 

 0xE8: Set slot parameter error 

 0xE9: Set RSTi bus parameter error 

 0xEA: Slot warm-start error 

 0xEB: Get slot catalog number error 

 0xEC: Invalid slot request 

 0xED: Firmware fault 

 0xEE: Set word-type error 

 0xF0: Vendor code fault 

 0xFF: Not ready 
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Diagnostics 

How to diagnose by LED Indicator 

The following table lists the LED Color, status, and the action to be taken during 

troubleshooting. 

Table 33: LED Indicators 

Color Status Action 

All LED turns off 

 No power  Check main power Cable 

 System power is not 
supplied. 

 Contact Sales team and 
send module for repair. 

MOD LED flashes 
green 

 Failure of initialization 
EEPROM parameter. 

 Contact Sales team and 
send module for repair. 

MOD LED flashes 
red 

 Excess of IO Modules 
connected 

 Excess of IO size 

 Wrong IO composition 

 Occurrence of EEPROM 
checksum error 

 Use IO modules up to 32. 

 Compose that IO total size 
is not excess. 

 Check composition I/O 
Module 

MOD LED is red 

 Wrong address ID 

 Occurrence critical error in 
firmware 

 Contact Sales team and 
send module for repair. 

I/O LED turns off 

 Failure of realization IO 
Module 

 None IO Module 

 Check connector status 
both RSTi series and IO 
module. 

I/O LED flashes 
red 

Failure of configuration baud rate 

 Check communication 
cable with Master 

 Check power for master. 

Failure of initialization I/O 

 Use IO modules up to 32 

 Compose that IO total size 
is not excess. 

RSTi series notice unidentified IO 
module ID. Check status of IO 
module. 

I/O LED is red Failure of exchanging I/O data Check status of IO connection. 

NET LED turns off Failure of communication with Master 
Check main power for master and 
communication cable. 

NET LED flashed 
green 

Failure of exchanging data with 
master 

Check status in software for Master 
configuration. 

NET LED is red Communication connecting lost 

Check BUS line cable for 
connection with master. 

Check duplication address. 

How to diagnose when device cannot communicate to network 

■ Inspection of wrong or omission cable connection 
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 Check status of cable connection for each node. 

 Check that color matches between connector and cable. 

 Check wire omission. 

■ Terminator resistor 

 If terminator resistor is not installed, install terminator resistor. 

 Check location of terminator resistor. 

■ Configuration of Node address 

 Check duplication node address. 

■ Configuration of Master 

 Check configuration of master. 

 Check whether to download. 

 Check composition is right 

■ Configuration of communication baud rate 

■ I/O size 

■ Configuration of each nodes 

■ Ground and environment  

 Check ground is contacted 

 Check environment factor (temperature, humidity, and so on) is less than regular 

limit. 
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PROFINET Network Adapters 
 

The Adapter, STXPNS001 is connected with PROFINET by means of RS-45 Connector 

and supports PROFINET I/O RT Protocol.  

STXPNS001 works as PROFINET IO Device in the PROFINET I/O Controller/Device 

environment. It can control a maximum of 2,024 digital input/ 2,024 digital output, or 

64analog input/64 analog output channels.  

 It is configured into the PROFINET connected with EtherNet by means of Line or Star 

topology. The station depends on EtherNet Specification. 
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STXPNS001 

Interface and Data 

The following screenshot shows the interface design for STXPNS001. 

 

 
Figure 36: PROFINET Network Adaptor Module: STXPNS001 

The following table lists the pin numbers and their description for STXPNS001. 
 

Table 34: STXPNS001: Pin Description 

Pin Number Description Pin Number Description 

0 Input Channel 0 1 Input Channel 1 

2 Input Channel 2 3 Input Channel 3 

4 Input Channel Common (0V) 5 Input Channel Common (0V) 

6 Chassis Ground/Shield 7 Chassis Ground/Shield 

 

  



 

GFK-2746 Chapter Chapter 
1 Introduction 5-3 

5     

Specification 
The following table describes the Interface Specifications and General Specifications of 
STXPNS001. 

 

Table 35: STXPNS001:  General and Environment Specifications 

Items Specification 

Communication Interface Specifications 

Protocol PROFINET IO RT 

Station type PROFINET IO Device 

Topology Line or Star topology 

Number of Nodes Limited by the IP address 

Number of Expansion I/O slots Maximum 32 slots 

I/O Data Size 252 Bytes inputs/252 Bytes outputs 

Indicators 1 green/red MOD Status Indicator 

1 green/red NET Status Indicator 

1 green/red IO Status Indicator 

1 green Port1 Link/Active Status Indicator 

1 green Port2 Link/Active Status Indicator 

1 green Field Power Status indicator 

Communication Rate 10*/100Mbps   *10Mbps for FTP only 

Module Location Starter module - left side of RSTi system 

General Specification 

System Power Supply voltage : 24Vdc nominal 

Supply voltage range : 11~28.8Vdc 

Protection : Output current limit (Minimum 1.5A) 

Reverse polarity protection 

Power Dissipation 115mA typical @24Vdc 

Current for I/O Module 1.5A @5Vdc 

Isolation System power to internal logic: Non-isolation 

System power to I/O driver: Isolation 

Field Power Supply voltage: 24Vdc nominal 

Supply voltage range : 11~28.8Vdc 

Current in Jumper Contacts DC 10A Maximum 

Weight 150g 

Module Size 45mm x 99mm x 70mm 

Environment Condition See “Environmental Specifications" in Appendix A. 
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LED Indicators 

Module Status LED (MOD) 

 

Table 36: STXPNS001: Module Status LED 

Color  Status Function 

Off Power off 

H/W Fault 
No power is supplied to the unit. 

Green Invalid boot image header 

(Flash), ROM Boot loader 

The unit has occurred 

unrecoverable fault in self-testing. 

 Firmware fault 

Flashing Red (0.5S)  Invalid RAM Image 

Flashing Red (0.1S)  OS Fatal error is occurred 

Flashing Green 
(0.1S) 

 
OS Handle Unexpected 

Exceptions 

Green On 
Normal Operation 

The unit is operating in normal 

condition. 

Network Status LED (NET)  

 

Table 37: STXPNS001: Network Status LED 

Color  Status Function 

Off 

Power off 

No Connection has been 
established with IO-
controller. 

Device is not on-line or may not be 
powered. 

Flashing Red (0.1s) Invalid Configuration Invalid Configuration 

Flashing Green 
(0.1s) 

Wait parameters 
PROFINET IO connection has been 
established. 

Red  PROFINET IO connection is aborted 
after a data exchange has taken 
place. 

Flashing Red (0.5s)  PROFINET IO connection is aborted 
before a data exchange has taken 
place. 

Flashing Green 
(0.5s) 

 PROFINET IO Data Exchange stop 

Green  PROFINET IO Data Exchange Run 
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IO Module Status LED (I/O)  

 

Table 38: STXPNS001: IO Status LED 

Color  Status Function 

Off 
Not Powered 

No IO Module 

Device has no IO module or may not 
be powered 

Flashing Green RSTi Bus On-line 

RSTi Bus is on-line but does not 
exchanging I/O data 

  

Green RSTi Bus Connection 
IO module is connected and run 
exchanging I/O data 

Flashing Red RSTi Bus connection fault   

One or more IO module occurred in 
fault state. 

 Changed IO module 
configuration. 

 RSTi Bus communication 
failure. 

Red IO Configuration Failed 

Failed to initialize IO module 

 Detected invalid IO module 
ID. 

 Overflowed Input / Output 
Size 

 Too many IO module 

 Initial protocol failure 

 Mismatch vendor code 
between adapter and IO 
module. 

Field Power Status LED   

 

Table 39: STXPNS001: Field Power Status LED 

Color  Status Function 

Off Not Supplied Field Power Not supplied 24Vdc field power 

Green Supplied Field Power Supplied 24Vdc field power 

 

Port1, Port2: Link and Activity   

 

Table 40: STXPNS001: Port1, Port2: Link and Activity 

Color  Function 

Green On Link is up (Physical connection is established) 

Flashing Green Active is present 

Off Link is down 
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PROFINET Module Installation 

STXPNS001 Dimension 

The following screenshot displays the dimension for STXPNS001. 

 

 
Figure 37: Dimension for STXPNS001 

Mechanical Set Up 

Total Expansion 

The number of the module assembly that can be connected is 32. So the maximum length 

is 426mm Exception. 

ST-2748 is expected to calculate maximum length because it is a double width module. 

Plugging and Removing the Components 

Caution 

Before work is done on the components, the voltage supply must be turned off. 

 

 

As the above screenshot indicated below, in order to safeguard the RSTi module from 

jamming, it should be fixed onto the DIN rail with locking level. To do so, fold on the upper 

of the locking lever. 

 

To pull out the RSTi module, unfold the locking lever as shown below. 
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Figure 38: Removing RSTi module from DIN rail 

Internal RSTi Bus/Field Power Contacts 

Communication between the RSTi series and the IO module as well as system/field power 

supply of the bus modules is carried out by means of the internal bus. It is comprised of 6 

data pin and 2 field power pin. 

 

 
Figure 39: Internal RSTi Bus 

 

Caution 

Do not touch data and field power pins, in order to avoid soiling and damage by 

ESD noise. 
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RSTi bus Specification 

RSTi bus System 
The following screenshot displays the RSTi bus system. 

 

 
Figure 40: RSTi bus System  

 

■ Network Adapter Module: The Network Adapter Module forms the link between the 

field bus and the field devices with the IO Modules. The connection to different field 

bus systems can be established by each of the corresponding Network Adapter 

Module, for example, for SyncNet, PROFIBUS, CANopen, DeviceNet, Ethernet/IP, 

CC-Link, MODBUS/Serial, MODBUS/TCP, and so on. 

■ IO Module: The IO Modules are supported by a variety of input and output field 

devices. There are digital and analog input/output modules and special function 

modules. 

■ Two types of RSTi bus Message: 

 Service Messaging 

 I/O Messaging 
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RSTi bus Pin Description  

The following table describes the RSTi bus pin and description. 

 

Table 41: RSTi bus Pin and Description 

No.  Name Description 

9.  Vcc System supply voltage (5Vdc) 

10.  GND System Ground 

11.  Token Output Token output port of Processor module 

12.  Serial Output Transmitter output port of Processor module 

13.  Serial Input Receiver input port of Processor module 

14.  Reserved Reserved for bypass Token 

15.  Field GND Field Ground 

16.  Field Vcc Field supply voltage (24Vdc) 
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PROFINET Communication Interface 

PROFINET Communication Interface for STXPNS001 

 

 

 
Figure 41: Shielded RJ-45 Socket 

 
The following table describes the Signal Name and Description. 
 

Table 42: Signal name and Description 

RJ-45  Signal Name Description 

10.  TD+ Transmit + 

11.  TD- Transmit - 

12.  RD+ Receive + 

13.  -  

14.  -  

15.  RD- Receive - 

16.  -  

17.  -  

Case Shield  

 

Warning 

The use of an incorrect supply voltage or frequency can cause severe damage to 

the component. 
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PROFINET Parameterization by Rotary Switch 

 

Table 43: Rotary switch: Values and Description 

Value Description Factory Setting 

0 

 Name of the station will be 
read from flash memory. 

(For example,STXPNS001-1) 

 IP address will be read from 
flash memory. 

Name of station : STXPNS001 

 IP address:192.168.0.100 

 Subnet mask: 255.255.255.0 

 Gateway: 192.168.0.1 

1~99 

 Name of the station will be 
STXPNS001-xx. 

(xx is the value of Rotary 
Switch) 

 IP address will be read from 
flash memory. 

 

■ When the rotary switch is not set to non-zero (1~99): 

If the decimal value of the rotary switch is not zero (0), the name of device will be fixed as 
“STXPNS001-xx” (xx: 1~99). You must put the fixed device name. 
 

 

■ When the rotary switch is not set to zero (0): 

If the decimal value of the rotary switch is set to zero (0), the device name will be read 
from non-volatile memory. You should put the same name as the name from non-volatile 
memory. If you want to read the name in non-volatile memory, please refer to Editing 
Ethernet nodes. 
 
STXPNS001 Devices on a PROFINET subnet must have unique names. The device 
names must satisfy the following DNS naming conventions: 

 Names are limited to a total of 127 characters (letters, numbers, dashes or dots). 

 Any component part (that is, a character string between two dots) of the device 

name may only be up to 63 characters long. 
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 Names cannot contain any special characters such as umlauts, parentheses, 

underscores, forward or backward slashes, empty spaces, and so on. The dash is 

the only special character allowed. 

 Names must not begin or end with the "-" or "." characters. 

 Names must not have the format n.n.n.n (where n = 0...999). 

 The device name must not start with numbers. 

 Names must not begin with the character sequence "port-xyz-" (where x, y, z = 

0...9). 

 If you want to change the IP address in non-volatile memory, please refer to 

Configuration section for more details. 

 
Device names are assigned to PROFINET IO device when the device is being set up and 
placed in operation for the first time ("commissioned"). 
 
The default name is “STXPNS001-SW” (see "Short Designation"). 
If several devices of the same type are arranged on the same PROFINET IO system, then 
PME/ Programing software automatically adds sequential number to the name from the 
GSD file. In this case, the second device has the extension "-1", the third one has the 
extension "-2", and so on. 
 

■ Communication Speed Setting 

 Refer to GEIP PROFINET master module settings to change the communication 

speed (GE-IP Profinet Controller User Manual- GFK-2571). 
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I/O Process Image Map 
An IO module may have three types of data as I/O data, configuration parameter, and 
memory register. The data exchange between network adapter and IO modules is done 
by means of an I/O process image data by RSTi bus protocol.  
 
The following screenshot shows the data flow between network adapter and IO modules. 
 

 
Figure 42: Data Flow between Network Adapter and IO Modules 
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STXPNS001 Parameter Settings 

STXPNS001 Parameter 

The following table describes the STXPNS001 parameter settings.  

 

Table 44: STXPNS001: Parameter Setting and Description 

Parameter Setting Description 

Word data type MOTOLORA * Big Endian format(MSB-LSB) 

INTEL Little Endian format(LSB-MSB) 

Stop action Clear output image to 0 * All outputs are set to 0. 

Hold last valid output image All Outputs hold the last valid 
output values. 

Depends on IO’s fault action 
parameters 

The communication between 
STXPNS001 and modules will be 
stopped and each module will 
control its IO Data according to 
the Fault Action selected for it. 

Reaction on RSTi Bus error Clear input image The input values are cleared 

Hold last image The input values hold the last 
valid values. 

Auto reset * STXPNS001 performs reset. 

Disconnect PROFINET Stop the communication with 
Controller. 

* Default settings 
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PROFINET Module Configuration 

Configuring an I/O Station for PROFINET Communication 

To configure I/O station, add a GE-IP Profinet master module at the desired slot in the 

RX3i PME project. Ensure that you have the latest GSDML file imported. Right click on 

master module and choose “Add IO Device”. Select “STXPNS” for PROFINET Network 

adapter and Select “OK”. For latest GSDML file, please visit GE-IP support site. 

 

 
Figure 43: PROFINET Device Catalog 

 

In order to add IO modules in this node, right click on recently added network adapter 

node and select “Change Module List”; a pop up window will open as shown below: 
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Figure 44: Change Module List 

 

Now start adding the IO modules as per the physical setup; after you add all the desired 

IO modules, select “OK”. 

 

To configure Profinet network adapter configuration, right click on the Profinet adapter 

node and select “Configure”, a  indo   ill open as sho n belo : 

 

 
Figure 45: Configuring PROFINET Adapter 

 

There are three tabs in this window IO Device Access point, STXPNS Parameters, and 

GSDML details. 

Choose “STXPNS Parameters” for parameter settings. There are three options: 

1. Word Data Format: The options are MOTOROLA & INTEL. MOTOROLA format 

is big endian; therefore ensure that the IO modules connected to the node are 
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configured with "False" for the swap bytes input for proper operation. INTEL 

format is little endian, therefore ensure that in the IO modules connected to the 

node are configured with "True" for the swap bytes input for proper operation. 

2. Stop Action: If a network fault is detected within the specified watchdog time 

base, the outputs of a slot under test of I/O station will acquire output values as 

per the options specified in DP clear action. The options are: 

a. Clear Output images to 0: The communication between STXPNS001 and 

slots will run. All outputs of Slot will be cleared. The output value should 

be set to '0' but Bus will run (IO status LED would be green) 

b. Hold Last Valid Output image: The communication between STXPNS001 

and slots will run. All outputs of Slot will hold last value but Bus run (IO 

status LED would be green) 

c. Depends on IO Fault Action Parameters: The communication between 

STXPNS001 and slots will be stopped. Slots will control IO Data by itself. 

The output value should be ON/OFF by Fault action which it is depended 

on IO fault action.  Bus should be ready status (IO status LED would be 

blinked). In order to configure the I/O module for fault action, go to 

“Modules” tab and select properties. For example, I have used ST-4522. 

Upon network fault, a user can configure the Module action as shown 

below. Note that substitute value low or high denotes low or high byte 

values. 

 

Figure 46: Module Parameters tab 

 

3. Reaction to Bus Error: If Bus error is detected, the behavior of the network 

module will be as per the options selected below: 

a. Clear Input Image: Input values will be zero. NET LED will be Green. 

Network adaptor communication with master intact. IO LED will be red 

and fault “Loss/addition of device' logged in I/O fault table. Ensure that –
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Force OFF- is set for the Inputs Default at “IO device Access point tab for 

successful operation. 

b. Hold Last Image: Input values will be holding. NET LED will be Green. 

Network adaptor communication with master intact. IO LED will be red 

and fault “Loss/addition of device' logged in I/O fault table. Ensure that –

Hold last State- is set for the Inputs Default at “IO device Access point tab 

for successful operation. 

c. Auto Reset: This option will reset the profinet Adapter module. 

d. Disconnect Profinet: Last input values will not hold. NET LED will be 

blinking Green. Network adaptor communication with master stops .IO 

LED  ill be red and fault “Loss/addition of device' logged in I/O fault table. 

 

Note: Refer to the examples section in the power modules chapter in New Slice IO 

manual for more details about the IO node configuration using the different power 

modules.  

 

  



 

GFK-2746 Chapter Chapter 
1 Introduction 5-19 

5     

STXPNS001 PROFINET IO Characteristics 

Device Identity 
Table 45: STXPNS001: Device Identity 

Item Value 

Vendor GE Intelligent Platforms 

Vendor ID 0x015A 

Product family GEIP RSTi System 

Device ID 0x9187 

Details STXPNS001 PROFINET IO Device 

Device Access Point 

Table 46: STXPNS001: Device Access Point 

Item Value 

Module Ident Number 0x00009187 

Details STXPNS001 PROFINET IO Device 

Vendor Name GE Intelligent Platforms 

Order Number STXPNS001 

Category STXPNS Network Adapter 

Software Version V20.000 

Hardware Version V20.000 

Maximal Input Length 252 Bytes 

Maximal Output Length 252 Bytes 

Physical Slots 0..32 

Minimal Device Interval 4 ms 

Based on NS9360 

DNS Compliant Name STXPNS001-address 

Supports Extended Assignment of IP 
Address 

No 

Fixed in Slots 0 

Instance Field of the Object UUID 1 

Supports Multiple Write No 

Requires IOPS/IOCS Yes 

Requires Engineering tool which supports 
at least GSDML Version 

V2.0 
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Sub-slot of STXPNS001 
Table 47: STXPNS001: Sub-slot 

Item Value 

Sub-slot Number Sub-slot Label 

32768 (0x8000) X1 

32769 (0x8001) X1 P1 

32770 (0x8002) X1 P2 

For more Details of the GSDML file, click on “Tool chest”, choose “Profinet Devices”, 

select the desired profinet network adapter and hit F1 to see the contents of the GSDML 

file. 
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Diagnostics 

How to diagnose by LED Indicator 

The following table lists the LED Color, Status and the action to be taken while 

troubleshooting. 

Table 48: LED Indicators 

Color Status Action 

All LED turns off 

 No power  Check main power Cable 

 System power is not 
supplied. 

 Contact Sales team and 
send module for repair. 

MOD LED flashes 
green 

 Failure of initialization of 
EEPROM parameter. 

 Contact Sales team and 
send module for repair. 

MOD LED flashes 
red 

 Excess of IO Modules 
connected 

 Excess of IO size 

 Wrong IO composition 

 Occurrence of EEPROM 
checksum error 

 Use IO Modules up to 32. 

 Compose that IO total size 
is not excess. 

 Check composition I/O 
Module 

MOD LED is red 

 Wrong address ID 

 Occurrence of critical error 
in firmware 

 Contact Sales team and 
send module for repair. 

I/O LED turns off 

 Failure of realization IO 
Module 

 No IO Module connected 

 Check connector status 
both RSTi series and IO 
module. 

I/O LED flashes 
red 

Failure of configuration baud rate 

 Check communication 
cable with Master 

 Check power for master. 

Failure of initialization I/O 

 Use IO Modules up to 32. 

 Compose that IO total size 
is not excess. 

RSTi series notice unidentified IO 
module ID. Check status of IO 
module. 

I/O LED is red Failure of exchanging I/O data Check status of IO connection. 

NET LED turns off Failure of communication with Master 
Check main power for master and 
communication cable. 

NET LED flashed 
green 

Failure of exchanging data with 
master 

Check status in software for Master 
configuration. 

NET LED is red Communication connecting lost 

Check BUS line cable for 
connection with master. 

Check duplication address. 

How to diagnose when device cannot communicate to network 

■ Inspection of wrong or omission cable connection 
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 Check status of cable connection for each node. 

 Check that all color matches between connector and cable. 

 Check wire omission. 

■ Terminator resistor 

 If terminator resistor is not installed, install terminator resistor. 

 Check location of terminator resistor. 

■ Configuration of Node address 

 Check duplication node address. 

■ Configuration of Master 

 Check configuration of master. 

 Check whether to download. 

 Check composition is right. 

■ Configuration of communication baud rate 

■ I/O size 

■ Configuration of each nodes 

■ Ground and environment  

 Check ground is contacted. 

 Check environment factor (temperature, humidity, and so on) is less than regular 

limit 
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IO Guide Pro 
 

IOGuidePro is an application program for the RSTi family manufactured by GE Intelligent 
Platforms. With IOGuidePro, user can calculate power consumption in the system and 
make a system configuration virtually in online and offline mode respectively. It provides 
user with significant information to save time to configure a system. 

 

IOGuidePro manual consists of the following: 

■ Installation: shows how to install and provides installed folder/file information. 

■ User Interface: shows several interfaces such as Menu, Toolbar, and Main Window. 

■ Using IOGuidePro: shows procedure, methods, and how to obtain the desired result. 

■ Tools: explains function of Bootp Server and Protocol Messenger. 

■ Error Code: explains the error listed in Validation Error Code and Application Error 

Code. 
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Notation 
The notations used in this document are as given below: 

 

1. A Procedure component in displayed in Italic. 

Example: 'Next ' 

2. Note is displayed as below.  

Example: note that input Project Name. 

 

Note: Project Name does not allow these characters: /: \" *? \\ < >.  

 

3. Normally function explains as an example but in vacant case function does not 

support.   

Example: In case of Automatic Scan, choose from the options mentioned below 

for creating a new project. 

 

Menu File → Project File → Ne  

Toolbar  

Shortcuts Ctrl + N 

 

4. Refer to Hyperlink   

Example: refer to 'System Requirement' Page    

               Refer to  System Requirement  

5. NA stands for 'Network Adapter'.   
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System Requirement 

PC Requirement 

Item Description 

OS 
Windows NT 4.0 (SP>3), Windows 2000, XP, Vista 
and Windows 7 

CPU 200MHz 

Memory 64MB RAM  

Hard Disk  60MB of free hard disk space  

Communication Ethernet Port, Serial Port  

 

Note: 64bit OS has not been tested yet.  

Offline Support 

 

Item Description 

Only Offline Support STXPBS001 
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Installation 
This topic describes how to install IOGuidePro. 

 

■ Setup: Installation Program consists of Wizard structure. The dialog in each page 

guides you how to proceed further. 

■ Installed Files: Consists of details of files and folder after performing installation.  

Setup 

How to start 

Automatically Insert CD into Optical CD-ROM Drive. 

Manually 
Execute Windows Explorer and insert CD into Optical 
CD-ROM Drive, then double-click Setup.exe.  

Setup Procedure 

 
[Page 1] Select language and click 'Next '.  
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[Page 2] Click 'Next '.  
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[Page 3] Choose 'I accept ... ' and click 'Next '. 
 

 
[Page 4] Enter the 'User Name' and 'Company Name' and then click 'Next '.  
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[Page 5] Choose 'Complete' and click 'Next '. 
If necessary to change the install folder, choose 'Custom' and then click 'Next'.  
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[Page 6] Click 'Install'.  
 

 
[Page 7] The actual file starts getting installed.  
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[Page 8] Click 'Finish' when the install is completed.  



 

 

5-10 RSTi Network Adapter Manual  User Manual -January 2012 GFK-2746 

5     

Installed Files 

Setup Program provides file and folder information to install in the PC. 

 

Folder/File Description 

 docuRSTi.exe Documentation execute file 

 IOGuidePro.chm Help file 

 IOGuidePro.exe IOGuidePro execute file 

 IOGuidePro.xml IOGuidePro Configuration file (Authority required) 

 *.dll  

 [~tmp] 
Temporary Folder (Related programs are automatically 
deleted as programs are closed.) 

 [Image] Graphic Image Folder (Mandatory) 

 [Log] 
Log File Folder (Related files are automatically deleted 
according to setup value.) 

 [Products] Product Definition Folder (Mandatory) 

 [Projects] User Project Save Folder  

 [StartUpOffline] StartUp Page Folder (Mandatory) 

 [Tools] Tool execute file Folder (Mandatory) 

 

Note: Do not delete files and folder related to a program.  
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User Interface 

 
Figure 1: IOGuidePro: User Interface  

 

 

■ Menu: Lists the Menu for IOGuidePro.  

■ Toolbar: Displays the frequently used menu.  

■ Project Window: Displays the currently active Project in a tree type. 

■ Log Message Window    

 All Tab: Displays all logs irrespective of the nature of the log. It consists of all the 

error, general, communication, and developer logs. 

 Error Tab: Displays the log for an error that has occurred. 

 General Tab: Displays the current basic function log.   

 Communication Tab: Displays the log for action related to communication. 

 Developer Tab: Displays the log which requires technical support and needs to be 

noticed. 

■ NA and IO List Window: Displays all available Network Adapter modules and IO 

modules  

■ Main Window    

 Start Page Tab: Allows homepage browsing 

 Image Tab: Displays currently activated image and information   

 Process Image Tab: Displays IO information 
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 Parameters Tab: Displays NA and IO parameter which can be changed. 

 Comment Tab: Allows to edit and save an user's comment  

■ Editing Grid: Describes a method of control Grid Type. 

■ Keyboard Shortcuts: Describes how to use shortcuts that enable to produce results in 

a relatively shorter time. 

■ Context Menu: Offers a limited set of choices that are available in the current state, or 

context.  
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Main Menu 

File 

Menu Sub Menu Description 

Project New Creates a new project 

 Open Opens the saved project 

 Close Closes the current project  

 Save   Saves the current project  

 Save as  Save the current project in a new name  

Documentation Project  
Make documentation as desired in PDF or 
Excel format for the selected Project 

 Network Adapter  
Make documentation as the setting for the 
selected NA  

Inquiry Project  
Provides information on how many 
quantities are used in the project  

 Network Adapter  
Provides information on how many 
quantities are used in the selected NA  

Recent File   Displays the latest activated  project file  

Exit   Closes the program 

Edit 

Menu Sub Menu Description 

Add  Network Adapter 
Adds network adapter (NA) to the selected 
project 

  Module  Adds IO module to the selected NA 

Move up    Move up the selected IO module  

Move down    
Move down the selected Project, NA and IO 
module  

Delete    
Deletes the selected Project, NA and IO 
module  

Rename    
Changes the name of the selected IO 
module or NA  

Properties   
Details properties information of the 
selected NA and IO module   

Check Validation    Project  Checks setup error in the selected project  

  Network Adapter  Checks setup error of the selected NA  

Reset to Factory 
Default 

  
Reverts back the parameter configuration 
settings and corresponding values to default 
factory settings 
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View 

Menu Description 

View Address Map  Displays address map of the selected NA 

Standard Toolbar  Choose to activate toolbar 

Status Bar  Choose to activate status bar  

NA and IO List  Choose to activate NA and IO list window  

Online 

The Online menu is only available for Modbus and not for PROFIBUS and PROFINET. 

Menu Description 

Automatic Scan 
Search NA which is connectable and upload searched NA and IO 
information. 

Compare with Offline (NA) 
Comparing Project NA in editing with Online NA at the point of 
structure between NA and parameter information. 

Download  
Download IO and Parameter Value modified in Project into Online 
NA.  

Upload  
Upload IO and Parameter Value of Online NA. At that time, the set 
value of Project does not change.  

Reset Parameter  Reset Parameter Value of Online NA or IO with Factory Default.  

Copy to Project  
Change Project value into NA or IO value of Online NA or Parameter 
Value.  

Special Commands (NA)  Transfer, Reboot, or Reset Error result to Online NA.  

Start Monitoring  Begin monitoring the whole of NA in Project. 

Stop Monitoring  Close monitoring the whole of NA in Project.  

Option 

Menu Description 

Configuration  Change parameter of IOGuidePro program 

Tools 

Menu Sub Menu Description 

Bootp Server    
Set IP Address of the product which 
supports Bootstrap Protocol 

Protocol Messenger   Modbus 
Low Level Communication in the 
selected protocol 

Help 

Menu Description 

IOGuidePro  Display manual of IOGuide Pro 

RSTi Technical Data  Display technical data of RSTi products 

About IOGuidePro  Display version information of IOGuidePro.  
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Toolbar 

[Standard] Toolbar 

 

 

Icon Title Menu Description 

 New File → Project File → Ne  Create new project 

 Open File → Project File → Open Open the saved project 

 Save File → Project File → Save Save current project 

 About   Help → About IOGuidePro  
Show version information of 
IOGuidePro 

[Add] Toolbar 

 

 

Icon Title Menu Description 

 
Add Network 
Adapter 

Edit → Add  → Network 
Adapter 

Add network adapter to the selected 
project 

 Add Module Edit → Add  → Module Add IO module to the selected NA 

[Modify] Toolbar 

 

 

Icon Title Menu Description 

 Move Up Edit → Move Up Move up the selected IO module 

 Move Down Edit → Move Down Move down the selected IO module 

 Delete Edit → Delete Delete the selected item 

[Online] Toolbar 

 

 

Icon Title Menu Description 

 
Automatic 
Scan 

Online → Automatic Scan 
Move up the selected IO module 

 
Compare with 
Offline 

Online → Compare with 
Offline 

 

 Download Online → Download Delete the selected item 

 Upload Online → Upload  

 
Reset 
Parameter  

Online → Reset Parameter 
 

 
Copy to 
Project 

Online → Copy to Project 
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Start 
Monitoring 

Online → Start Monitoring 
 

 
Stop 
Monitoring 

Online → Stop Monitoring 
 

[Validation] Toolbar 

 

 

Icon Title Menu Description 

 
Project 
Validation 

Edit → Check Validation  → 
Project 

Check setup error in the selected 
project 

 NA Validation 
Edit → Check Validation  → 
NA 

Check setup error in the selected NA 

[Document] Toolbar 

 

 

Icon Title Menu Description 

 
Project 
Documentation 

File → Documentation  → 
Project 

Make documentation as desired in 
the selected project 

 
NA 
Documentation 

File → Documentation  → 
NA 

Make documentation as the setting of 
selected NA 

[Inquiry] Toolbar 

 

 

Icon Title Menu Description 

 
Project 
Documentation 

Edit → Inquiry → Project 
Provides information how many 
quantities used in the project 

 
NA 
Documentation 

Edit → Inquiry → NA 
Provides information how many 
quantities used in the selected NA 

[Mode] Toolbar 

 

 

Icon Title Menu Description 

 
Change View 
Mode 

Edit → Inquiry → 
Project 

refer to User Interface - Project 
window page   

 
Change Analog 
Value Format 

Edit → Inquiry → 
NA 

refer to Using IOGuidePro - IO 
Test page   
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Project Window 

The Project window displays currently activated project in tree type.  

It has various display methods such as User View, Product View, and Description View. 

Through View Mode of Toolbar, it can be possible to change name format of NA and IO. 

View Mode 

The View mode is displayed on the [Mode] toolbar. By default, User View is displayed. 

 

 

Mode Description 

User View user defined name 

Product Display only model name 

Product, Desc Model name and main features are described shortly 

 

 

             User View             Product View         Product, Desc View 
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Log Message Window 

IOGuidePro consists of five categories which are displayed in Log Message. 

The Log category can be modified by means of Option → Configuration window. 

 

Tab Description 

All Displays log of all error, general, and communication messages 

Error Displays the log for occurred error   

General Displays current basic function log 

Communication Displays log for action related to communication   

Developer 
Displays log which requires technical support and needs to be 
noticed 

 

 

Figure 47: Log Message window  
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Network Adapter & IO List Window 

The Network Adapter and IO window displays the list of NA and IO to be connectable.  

Each technical data can be identified by a click. 

 

Tab Description 

All Displays log of all error, general, and communication messages 

Error Displays the log for occurred error   

General Displays current basic function log 

Communication Displays log for action related to communication   

Developer 
Displays log which requires technical support and needs to be 
noticed 

 

 
Figure 48: NA and IO list window  
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Main Window 

■ Start Page Tab: Homepage Browsing  

 
Figure 49: IOGuidePro Home page  

 
It is possible to configure 'Goto Online' link at Options → Configuration. 

 

Note: In case you want to change Start Page, please contact GE Intelligent Platforms. 

 

■ Image Tab: displays currently activated image and information  

The Image tab displays currently activated image and information 
Click image, then Properties of the selected device to display onscreen. 
 

1. Selection NA from Project Window 

 Name: Displays the name defined by user and the NA address is displayed in 

blue.  

 Description: Displays a brief explanation for the selected Network Adapter.  

 Total Power: Displays total power consumption of IO in the connected NA.  

 Total Size: Displays total size of IO and NA at current node 
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Figure 50: IOGuidePro: Image tab displaying NA 

 

2. Selecting IO from Project Window 

 Name: Displays the name defined by user; slot number is displayed.  

 Description: Displays a brief explanation for the selected IO.  

 Specification: Displays the main features for the selected IO 

 

 
Figure 51: IOGuidePro: Image tab displaying IO 
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■ Process Image Tab: displays IO information   

 Displays IO information  

 Possible to test IO Value 

 Able to test value of all connected IO modules in case of selecting Network 

Adapter.  

 Able to test value of Base IO in case of selecting all-in-one type of Network 

Adapter (A-series).  

 Download and apply to Online Device after changing value of Project.  

 To get the latest value in Online, device should be uploaded.  

 During monitoring, the latest update is automatically executed in Online Value    

 

 
Figure 52: IOGuidePro: Process tab  

 

■ Parameters Tab: displays RSTi Network Adapter & and IO parameter. This tab can 
be used to configure network adapter or IO parameters. Refer to GFK-2746 for more 
details on parameter configuration.   

 Displays NA and IO parameters.  

 Displays the slot number and the module name as defined by the user.  

 Download and apply to Online Device after changing value of Project.  

 To get the latest value in Online, Device should be uploaded    



 

GFK-2746 Chapter Chapter 
1 Introduction 5-23 

5     

 
Figure 53: IOGuidePro: Parameters tab  

 
 

■ Comment Tab:  Allows you to edit and save specific comments as per the application 
or module.    

 

Figure 54: IOGuidePro: Comments tab  
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Editing Grid 

IOGuidePro uses Grid Type of Control in various User Interfaces.  

All Grids have the same function so please study it carefully. 

 

■ Editing Parameters Configuration and Values   

Read-Only 
Cell with black characters and Gray Color 
Column/White Color Column 

Writable Cell with blue characters and White Color Column. 

 

 

 

■ How to edit   

1. Move to the required cell to edit (cell is displayed in red color)  

2. In case you are unable to edit, 'Allowed value' in the cell is displayed in a range as 

shown in the below image. 

 

 

3. Enter characters directly or click 'Enter' then input the value.  

After entering the value, click 'Enter' and move to another cell using the mouse. 

 

 

 

4. If value is invalid, an error message is displayed in Log Message Window, as 

shown in the below image. You can then return to the value that was present 

before editing.  
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Keyboard Shortcuts 

The following table lists the keyboard shortcuts. 

Shortcut Key Menu 

F1 Help 

Ctrl + N  File → Project File → New  

Ctrl + O  File → Project File → Open  

Ctrl + S File → Project File → Save 

Shift + P  File → Documentation → Project  

Shift + A  File → Documentation → Network Adapter  

Ctrl + A  Edit → Add → Network Adapter  

Ctrl + M  Edit → Add → Module  

Shift + Up-arrow Edit → Move Up  

Shift + Down-arrow  Edit → Move Down  

Ctrl + D  Edit → Delete  

Ctrl + R  Edit → Rename  

Ctrl + P  Edit → Properties  

Ctrl + Shift + P  Edit → Check Validation → Project  

Ctrl + Shift + A  Edit → Check Validation → Network Adapter  

Ctrl + Shift + M  View → View Address Map  

Shift + S  Online → Automatic Scan  

Shift + C  Online → Compare with Offline (NA)  

Shift + M  Online → Start Monitoring   

Shift + O  Online → Stop Monitoring  

Shift + B  Tools → Protocol Messenger → Modbus  
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Context Menu 
The two types of context menu supported in IOGuidePro are as given below. 
 

1. Case of IO selection from Project Window 

 At Project Window, R-Click is enabled to view Context menu.  

 Each function has the same feature as Select in Main menu.  

 
Figure 55: Selecting IO module from Project Window 

 

2. Context Menu in Log Message Window 

At Log Message Window, R-Click is enabled to view Context menu.  
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Using IOGuidePro 

Quick Start 

Offline Functions 

1. Create Project 

 Create a ne  project by selecting "Project File → Ne " from the Edit Menu. 

 From New project dialog, choose project name, Bus type and file save 

location and then click OK.  

2. Network configuration 

 Select network adapter in Edit menu. 

 From Add Network Adapter Dialog, choose desired network adapter to be      

added and setup communication exactly, then click OK. 

 Configure parameters in parameter tab of main window.  

3. IO configuration 

 Choose "Add Module" in Edit menu. 

 Choose IO to be added from Add IO Module Dialog.  

 After choosing IO in project window, set parameter value in parameter tab of 

main window. 

4. Validation Check 

 Choose “Check Validation → Project” in Edit menu. 

 Check error in Validation Result Dialog.   

5. Documentation 

 Choose “Documentation → Project” of file menu in order to make current 

project file. 

 Click "Make Report" in Documentation Dialog. 
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Setting Hardware 

In order to complete Online function of IOGuidePro, please complete Hardware Setting for 

communication. 

Modbus TCP/IP support Network Adapter.   

1. Connect IO module to Network Adapter. 

  Tips: Wire diagram for each IO module of RSTi Technical Data.  

2. Connect Cable (RJ-45) to Ethernet Port of PC. 

3. Charge up power in Network Adapter. 

Modbus Serial support Network Adapter.   

1. Connect Serial Cable to Serial Port in PC. 

2. Set Node Address. Be sure not to be duplicated in case of RS-485. 

  Refer to: RSTi Technical Data.  

3. If necessary, set Serial Communication option through DIP Switch. RS-485 

requires all the same. 

(Factory Default as Baud Rate: 9600, Data Bit: 8, Parity: None, Stop Bit: 1)  

  Refer to: RSTi Technical Data.  

 

Note: IOGuidePro supports RTU communication only, do not change Communication 

DIP Switch.  

 

4. In order to apply for the changed setting value, please newly charge up power in 

NA. 

  
        Refer to 
            System Requirement  

 
 RSTi Technical Data.  

 

   

  

mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
mk:@MSITStore:C:/Program%20Files/GE-IP/IOGuidePro/IOGuidePro.chm::/FnIO%20Information.htm
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Create Project 

Each Project holds its own Bus Type (protocol). Each Project contains network adapters 

compatible with specific Bus Type (protocol). Projects with supported bus type only can be 

identified by IOGuidePro tool.  

IOGuidePro can create and load several Projects. 

How to activate 

Menu File → Project File → Ne  

Toolbar  

Shortcuts Ctrl + N 

How to create Project   
 

 
Figure 56: New Project dialog box 

 

1. Enter 'Project Name'.  

2. Select 'Bus Type'. 

3. Browse to the 'Location' where Project file can be saved. 

4. Click 'OK' button. 

5. Create new project in Project Window. 

 

Note: If you try to open a Project which is already open, a warning message is 

displayed. Also, you are not allowed to use special letter such as / : \" * ? \\ < > |” 

in Project Name.  

 

Note: A created Project Name cannot be changed by Rename function. Use Save As 

function to apply to Project Window. 
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Add Network Adapter  

You can add network adapter to the selected project. 

How to Add to Network Adapter   

1. Select Project to be added to Network Adapters in Project window. 

2.  Use one of the following methods. 

Menu Edit → Add → Network Adapter 

Toolbar  

Shortcuts Ctrl + A 

 

 

Figure 57: Add Network Adapter window  

3. Select which Network Adapter should be added to. 

4. Set name and address shown in User View. 

5. Click 'Show Technical Data' and check its technical data. 

6. Click 'OK' and Network Adapter is added to Project. 
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Add IO Module  
Add IO module to the selected NA. 

How to Add to IO Module   

1. Select IO Module to be added to Network Adapter in Project window. 

2. Use one of the following methods. 

Menu Edit → Add → Module 

Toolbar  

Shortcuts Ctrl + M 

 

 

Figure 58: Add IO Modules window  

 

3. Double click to add IO Module or Click '>>' to add to NA. 

4. Enter a name in User Title form User View. 

5. Click 'Show Technical Data' to check Technical Data. 

6. Click 'OK' to add IO to NA. 
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Check Validation  

Validation allows you to check setup error in the selected project or network adapter. 

Through Error Code and description, it can be possible to know where problem exists. 

Procedure to Check Validation   

1. Select Project or Network Adapter for checking Validation in Project window. 

2. Use one of the following methods. 

Menu Edit → Check Validation → Project or Network Adapter 

Toolbar or  

Shortcuts Ctrl + Shift + P or Ctrl + Shift + A 

 

3. If no problem occurs in configuring Project or Network Adapter, then a "VALID" 

Message Box is displayed. 

4. If problem occurs in configuring Project or Network Adapter, then a message is 

displayed in Validation Result Dialog. 

5. Error Code and description are provided in Validation Result Dialog. 

 

 
Figure 59: Validation Result Dialog  
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Properties 

You can view the Properties in Selected NA and IO. 

Click 'Show Technical Data' and get information of Device 

Project 

Bus Type supporting Online can reconfigure 'Communication Interval' and 'View Update 

Time'. 

 
Figure 60: Properties window – NA module 

Network Adapter 

Modbus TCP/IP - allows ' IP Address' to be changed. The communication interval, IP, and 

so on are reconfigurable. 
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IO 

 
Figure 61: Properties window – IO module 
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Modify Configuration 

■ Move to the selected Module and Folder. 

■ Delete the selected item. 

■ Change User name of the selected item. 

Procedure to Move Up 

1. Select IO Module or Folder in Project window. 

2. Use one of the following methods. 

Menu Edit → Move Up 

Toolbar  

Shortcuts Shift + Up-arrow 

Procedure to Move Down 

1. Select IO Module or Folder in Project window. 

2. Use one of the following methods. 

Menu Edit → Move Down 

Toolbar  

Shortcuts Shift + Down-arrow 

How to Delete 

1. Select item to be deleted in Project window. 

2. Use one of the following methods. 

Menu Edit → Delete 

Toolbar  

Shortcuts Ctrl + D 

How to Rename 

1. Rename function is activated only when View Mode is 'User View'. 

 Refer to View Mode Change      

2. Select item to be renamed in Project window. 

3. Use one of the following methods. 

Menu Edit → Rename 

Toolbar  

Shortcuts Ctrl + R 

 

4. Enter a ne  name and click ‘OK’. 

 

 

.   
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View Address Map 

Displays Input/Output mode and Address Map in the selected node. 

Address value can be changed by project value. 

Procedure to View Address Map 

1. Select Network Adapter in Project window. 

2. Use one of the following methods. 

Menu View → View Address Map 

Toolbar  

Shortcuts Ctrl + Shift + M 

 

Note: This procedure is not supported for PROFIBUS. 
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Documentation 

It is possible to print information of selected project or NA or to save them as PDF, Excel 

file. 

Document contains the following: 

■ Communication Parameters of project or NA  
■ Drawing and actual dimension for the connection between NA and IO Modules 
■ IO Address Map 
■ Parameters for IO Module 
■ Inquiry information 

Documentation Procedure 

1. Select project or NA to make documentation in Project window. 

2. Use one of the following methods. 

Menu File → Documentation → Project or Network Adapter 

Toolbar or  

Shortcuts Shift + P or Shift + A 

 

 
 

 

Figure 62: Selecting Documentation procedure  

 

3. Select 'Make PDF file' if necessary to make PDF file. 

Select 'Make Excel file' if necessary to make Excel file. 

Click  button to browse to the desired location and file name. 

4. Check 'View PDF file' to identify the file. It requires Adobe Reader program for 

viewing. 
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Check 'View Excel file' to identify the file. It requires Microsoft Excel program for 

viewing.  

5. Click 'Make Report’. 
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Figure 63: Viewing Documentation output  
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Inquiry 

■ Inquiry displays inquiry information of selected project or NA. 

■ Check technical data of selected Module. 

■ Save inquiry information as CSV (Comma Separated Value) format. 

Inquiry Procedure 

1. Select project or NA to make inquiry in Project window. 

2. Use one of the following methods. 

Menu File → Inquiry → Project or Network Adapter 

Toolbar or  

Shortcuts  

 

 
Figure 64: Inquiry window  

 

3. Click 'Save to file ' to save Inquiry information as csv format. 
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Save Project 

Save current Project. 

How to save Project 

1. Select project to save in Project window. 

2. Carry on one of the below method 

Menu File → Project File → Save 

Toolbar  

Shortcuts Ctrl + S 

 

3. The Save As dialog box is created for projects that are already saved. 

 

Save As Project 

Save as Project. 

Save As Project Procedure 

1. Select project to save as in Project window. 

2. Use one of the following methods. 

Menu File → Project File → Save As 

Toolbar  

Shortcuts  

 

3. Enter file name in Save As Dialog and click 'Save '.  

4. The project name in Project window is changed. 

 

Note: If same name exists, the file gets automatically overwritten.  

Error message is displayed as the opened project name is being saved, which is 

actually incomplete. 

Project name does not contain special letters such as / : \" * ? \\ < > | .   
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Open Project 

Open saved Project. 

How to open Project 

1. Use one of the following methods. 

Menu File → Project File → Open 

Toolbar  

Shortcuts Ctrl + O 

 

2. Select Project to open and click 'OK'. 

 

Note: If a project is already opened, an error message is displayed.  
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Configuration 

Change parameter of IOGuidePro software  

As IOGuidePro restarts, a yellow icon is automatically applied. 

 

 

Property Sub Property Description 

Language  Setting Language 

StartUp View Title 
A title is displayed in Start Page Tab of 
Main Window 

 Path/Url 
Online link URL of Start Page Tab of 
Main Window 

View Mode  Default View Mode 

Project Default Folder  
Project Save/Open Default Folder 
Setting 

Log Option Maximum Log Display 
Setting the maximum row in Log 
Window 

 Maximum File Size (MB) Maximum Size for a Log file 

 Erase Old Log File (Days) 
Setting automatic deletion for the old 
Log file 

Log Window Enable General Info Setting Log enables for general display 

 Error Info Setting Log enables for error display 

 Communication Info 
Setting Log enables for communication 
display 

 Developer Info 
Setting Log enables for developer 
display 

Log File Enable General Info 
Setting File Log enables for general 
type 

 Error Info Setting File Log enables for error type 

 Communication Info 
Setting File Log enables for 
communication type 

 Developer Info 
Setting File Log enables for developer 
type 

 

 
Figure 65: Configuration window  
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Error Code 
Error Code list as IOGuidePro. 

 

■ Validation Error Code: Error Code list as 'Check Validation' activated.  

■ Application Error Code: Error Code Legend and each description.  

 

Validation Error Code 
 

Error Code Category Description 

-101  Power Maximum power exceeded. 

-102 Expansion Maximum IO expansion exceeded. 

-103 Input Size Maximum input size exceeded. 

-104 Output Size Maximum output size exceeded 

-105 Field Power 
Field power mismatches. Insert a power 
distributor module before this module. 

-106 Field Power 
First I/O of the network adapter must be a power 
distributor module. 

-107 NA Comm 
Communication setting of the network adapter is 
duplicated. 

-108 NA Comm 
Communication setting of the network adapter is 
empty. 

-109 NA Comm 
Port No is different. Muli-drop bus type must 
have same port. 

-110 NA Comm 
Comm. parameter is different. Muli-Drop bus 
type must have same communication parameter. 

Application Error Code 
 

Error Code Category Description 

-1000  Cannot find a selected project. 

-1001  TextID is undefined in listTextId.xml. 

-1002  Cannot create the temporary directory. 

-1003  
Cannot open the file during saving. Check if the 
file exists or using. File: 

-1004  
The project name exists in opened projects. 
Project: 

-1005  Out of memory 

-1006  Cannot save the file. Cause: . Path: . 

-1007  Undefined Wrapper type. May be bug. Type: 

-1008  Cannot find a selected Network Adapter 

-1009  Cannot run. 

-1010  Cannot find NA definition object. NA ID: 

-1011  Cannot find IO definition object. IO ID: 

-1012  Cannot get active view. May be bug. 

-1013  Error value is undefined in listError.xml 
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-1014  Cannot delete. Error code: 

-1015  Cannot get mainframe pointer. May be bug. 

-1016  Cannot load module's graph image. 

-1017  Cannot get setting value. See below log in detail. 

-1018  
Cannot delete the project file. Please input 
another project name. 

-1019  API Code: . Project : 

-1020  Cannot create new project directory. Path: . 

-1021  Cannot find Communication driver. File: . 

-1022  
Cannot create comm. driver instance. May be out 
of memory. NA: . 

-1023 Application 
Cannot find drvShowAddresMap function. 
Contact the dealer. NA: . 

-1024 Standard Error 
Cannot find drvGetAddresMap function. Contact 
the dealer. NA: . 

-1025 -1000 ~ -2000 
Cannot find drvSetModuleList function. Contact 
the dealer. NA: . 

-1027  
Cannot open the file. Check if the file exists or 
using. XML File: . 

-1028  Auto scan is failed. See below log in detail 

-1029  
Cannot find drvFreeGetAddresMap function. 
Contact the dealer. NA: . 

-1030  
Cannot find drvFreeGetIOConfig function. 
Contact the dealer. NA: . 

-1031  
Cannot get online data because CommOffset <= 
0. " 

-1032  
[Bug] Cannot get online data because 
iCommRxOffset < 0. 

-1033  
Cannot get online data because 
m_pOnlinValTotal is null. 

-1034  Comparison failed. See below log in detail 

-1035  
Cannot save the file. Check if the file exists or 
using. File: . 

-1036  Undefined help link path. Model:. 

-1037  Length is empty in XML. Name: 

-1038  Wrapper object is not NAUsr and IOUsr. Loc: 

-1039  
This version does not support the project that 
was created by version. Project file: 

-1040  
Project documentation failed. See below log in 
detail 

-1041  
Documentation of network adapter is failed. See 
below log in detail. 

-1042  Bus type does not support online. Bus type: . 

-1043  
Cannot find a selected item in project window. 
May be bug. 

-1044  Cannot find NA having product ID. 

-1045  Cannot find IO having product ID. 

-1046  Invalid sModType. 

-1047  Cannot find IO definition object. Product ID: 
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-1048  Cannot get online value. See below log in detail 

-4000  Node is not defined. Loc: xml file: 

-4001  Not allowed value in xml file. Value: . Loc: 

-4002  
Wrapper object is null. NA node is not defined 
Loc: 

-4003 XML Parsing Error Wrapper object is not NAUsr. Loc: 

-4004 -4000 ~ -4500 Wrapper object is not NAUsr and IOUsr. Loc: 

-4005  Unsupported datatype in XML. 

-4006  
Parameter's allowed value format is invalid in 
XML Parameter: . 

-4006  
Cannot find CommBlock Key. Please define the 
key in XML. Key: 

-3500 
App Warning 

-3500 ~ -3999 

[Warning: ] Comm. driver cannot be defined.  

So, some functions cannot be supported. NA: . 

-5000  

Create Resource 
Error 

Failed to create menubar because of resource 
lack.\Loc:  Error Code: 

-5000 ~ -5019 Mainframe. Only MessageBox 

-5020 ~ -5039 IOGuideExView. Message Box and log file 

-6000 Component Error 
Cannot create XML Parser. Please install xml 
parser. Loc: . 

-6001 -6000 ~ -6059 
Exception happened. Error Description Loc:. xml 
file: . 
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Tools (For Future Release) 

Bootp Server 

The Bootp Server describes how to activate external program. 

 

■ Bootp Server: Software using Bootstrap Protocol (RFC 951) is for IP Address setting 

to GE IP products.  

■ Protocol Messenger: Enables to read/write Address Data according to NA 

communication protocol. 

 

Note: Modbus TCP/Serial (RTU) only support.  

Bootp Server Software Using Bootstrap Protocol (RFC 951) is for IP Address setting to 

RSTi products. 

It provides the following: 

 

■ To set IP Address for device supporting Bootstrap Protocol. 

■ To reset Network default of device using Bootstrap Protocol. 

■ To set parameters for RSTi products supporting Modbus TCP/IP and Ethernet/IP. 
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Bootp Server General Description 

 

 

Request History 

■ Show only GE-IP device: option for displaying products with only MAC address of GE 

Intelligent Platforms 

■ Request History: a table received Bootp Request. 

■ Clear History: clear up a table data 

■ Start Bootp: display a received Bootp Request. 

■ Stop Bootp: stop displaying of the received Bootp Request. 

 

Request History 

■ Setup History Table: Display setup fulfilled 

■ Clear History: clear up the data described on Table 

■ Add New Device:  set IP Address of new device by inputting MAC address directly 

■ Reset with Network Default:  initialize network of device inputting MAC address 

directly or selected device from table. 
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Setup IP Address 

Automatic Setting 

1. Run Bootp Server software  

2. Press the button for Start Bootp to activate 

 

 

3. Double click device from the Request History Table. 

4. Select the right interface (LAN) from Setup IP Address Dialog. 

 

5. Set IP Address and click OK. 

6. Check the setting address in Setup History Table. 
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7. Using mouse, select device information from right click menu in Setup History. 

 

 

8. Set parameter in Dialog and click Close. 
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Manual Setting 

1. Click  "Add New Device" or select right click menu on mouse from Setup History 

Table 

2. Select the suitable interface (LAN) in Setup IP Address Dialog 

3. Click OK after entering all address information. 

 

 

4. Check the setting address in Setup History Table 

5. Using mouse, select device information from right click menu in Setup History 

Table. 

 

 

6. Set parameter in Dialog and click Close. 
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Reset IP Address 

1. Click "Reset with Network Default". In case of Device reset in Setup History, 

select the Device first and press the button. 

2. Fulfill MAC address of Dialog and press the button for OK. 
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Protocol Messenger 

Modbus 

1. Protocol: Modbus TCP/IP, Modbus Serial RTU 

 Data communication is possible at standard Modbus Protocol format. 

 Communication possible with all types of GE-IP's NAs for Modbus TCP/IP, 

Modbus Serial RTU. 

 Data is transferred after clicking 'Send' button as functions, address are set to 

protocol specification properly. 

2. Built-In Messages 

 The file saved for communication format used frequently 

 As select Built-In Message, type of Request is automatically selected. 

 Built-In Message file consists of standard csv format, which is possible to add 

and change 

3. Response Data format 

 Response Data format displayed in monitor can be changed. 

 Possible to change into 7 sorts of format. 
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Online Commands 
Online commands are only supported by Modbus and not applicable for 

PROFIBUS/PROFINET. 

Automatic Scan online only 

Screen a connectable Node and upload the searched Node information.  

Supports only Modbus Network Adapter.  

In case of TCP/IP Communication Network Adapter, the following information is available: 

■ IP Address, Subnet Mask, and GateWay Address in Network Adapter respectively 
■ Number of IO modules and Model name.   

In case of Serial Communication Network Adapter, the following information is available. 

■ Com Port and Node Address in Network Adapter 
■ Number of IO modules and Model name 

  How to Proceed   

Menu Online → Automatic Scan 

Toolbar  

Shortcuts Shift + S 

 

■ Automatic Scan – TCP/IP 

1. Step 1. From Selection Option, choose 'TCP/IP' option button.  

2. Step 2. From Scan, click 'Scan' button. 

■ Automatic Scan – Serial 

1. From 'Step 1. Selection Option', choose 'Serial (RTU/ASCII)' option button.  

2. Set range of Port and Node for scanning.  

Default Communication Parameter in Network Adapter has 9600, 8, None and 1. 

Thus change occurs, check Serial Communication Parameter 
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3. From 'Step 2. Scan', click 'Scan' button.  

Compare with Offline online only 

■ It compares information of node in online with current project. 
■ It can compare configuration with parameter. 
■ Additionally miscellaneous information provided with 

How to Compare 

1. Select Network Adapter to be compared in Project window. 

2. Use one of the following methods. 

 

Menu Online → Compare with Offline 

Toolbar  

Shortcuts Shift + C 

 

 
 

3. Select 'Parameters' option button in Step 2. Select scope. 

4. Click 'Start comparing' in Step 3. Apply.  

5. If online and offline are same, "EQUAL" Message Box is displayed.  

Otherwise, the result of it is displayed in the monitor. 

 

Note: If IO Configuration is not identified, comparing parameter does not work properly. 
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■ Applied result Automatic Scan 

1. From Step 3. Apply, choose options and click 'OK' button.  

Option Description 

Overwrite the project 
Erase NA which is already connected to Selected 
Project and open recently searched Network Adapter. 

Add to selected project 
Leave NA which is already connected to Selected 
Project, connect recently searched new NA  

Copy parameters As connect to searched NA, bring parameters. 

Copy output values As connect to searched NA, bring output values 
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Setup IO Parameters online only 

Parameters in Network Adapter or IO module can be changed.   

Move to Process Image Tab 

1. Select Process Image Tab in Main window. 

2. Select Network Adapter or IO Module to be tested in Project window. 

 

Network Adapter's Parameters 

 

IO module's Parameters 
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View Online Value 

1. Use one of the following methods. 

 

Menu Online → Upload 

Toolbar  

Shortcuts  

 

2. After communication completed, a value is displayed in 'Online Value'. 

Download Project Value 

1. Input parameter to download 'Project Value'.  

2. Use one of the following methods. 

 

Menu Online → Download 

Toolbar  

Shortcuts  

 

3. Communication completed, then a value is displayed in 'Online Value'. 

Copy Online Value to Project Value 

1. Use one of the following methods. 

 

Menu Online → Copy to Project 

Toolbar  

Shortcuts  

 

2. Communication completed, then current value is displayed in 'Project Value'. 

Initialized value of Online Parameter as Factory Default 

1. Use one of the following methods. 

 

Menu Online → Reset parameter 

Toolbar 
 

Shortcuts  

 

2. Communication completed, then current value is displayed in 'Online Value'. 
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Initialized value of Project Parameter as Factory Default 

1. Use one of the following methods. 

 

Menu Edit → Reset to Factory Default 

Toolbar  

Shortcuts  

 

2. An initialized value is displayed in 'Project Value’. 
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Send Special Command online only 

■ Restart the selected NA. 
■ Reset Error counter of selected NA.   

Start Monitoring online only 

■ Start monitoring for the selected Project. 
■ Status of communication and Network Adapter is displayed with icon of Project 

window. 
■ Online value in real-time between Process Image Tab and Parameter Tab 
■ As communication is discontinued after starting monitoring, it tries to reconnect 

periodically.   

How to Start Monitoring 

1. Select project to monitor in Project window. 

2. Use one of the following methods. 

 

Menu Online → Start Monitoring 

Toolbar  

Shortcuts Shift + M 

 

3. Change of icons is subject to communication and NA's status. 

 

■ Project Icon 

 

Icon Description 

 Offline status 

 Communication of all network adapters is good. 

 Communication of some network adapter has failed. 

 

■ Network Adapter Icon 

 

Icon Description 

 Offline status 

 Communication is good. 

 Communication has failed. 

 Communication is good, but IO error. 

 Communication is good, but field power is off. 

 Communication is good, but IO error and field power is off. 

 

Note: As monitoring Starts, each value in NA and Project becomes black letter and 

cannot change.   

 Related communication 

 Input/Output Image Mode, Watchdog Time in NA 
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Stop Monitoring online only 

Stop monitoring for the selected Project. 

How to Stop Monitoring 

1. Select project to stop monitoring in Project window. 

2. Use one of the following methods. 

 

Menu Online → Stop Monitoring 

Toolbar  

Shortcuts Shift + O 

 

3. As monitoring stops properly, icon of project and NA is changed accordingly. 

 

Icon Description 

 Offline status 

 Communication is good. 

 

IO Test online only 

It can change output value of IO Module and check input value.   

Move to Process Image Tab 

1. Select Process Image Tab in Main window. 

2. Select Network Adapter or IO Module to be tested in Project window. 

 

Select Network Adapter: All values are displayed in Hex Format. 

 

Select IO Module 
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View to Online Value 

1. Use one of the following methods. 

 

Menu Online → Upload 

Toolbar  

Shortcuts  

 

2. After completion, a value is filled in 'Online Value'. 

Download Output Value 

1. Input Value of output to download in 'Project Value'.   

2. Use one of the following methods. 

 

Menu Online → Download 

Toolbar  

Shortcuts  

 

3. After communication is completed the current value is displayed in 'Online Value '. 

Copy Output Value to Project Value 

1. Use one of the following methods. 

 

Menu Online → Copy to Project 

Toolbar  

Shortcuts  

 

2. After communication is completed the current value is displayed in 'Project Value'. 
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View Analog Value in various Data Format 

1. Use one of the following methods. 

 

Menu  

Toolbar 
 

Shortcuts  

 

2. Analog Normal Value: actual value displayed in unit of mA, V. 

 
 

3. Analog Raw Value (Dec): Raw Value of output is displayed in Decimal. 
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4. Analog Raw Value (Hex): Raw Value of output is displayed in Hexadecimal. 
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Product Certifications and Installation 
Guidelines for Conformance 
 

This appendix describes the compliance markings and standards to which the RSTi 

products have been certified. 

 

Important Notes 
Solid state equipment has operational characteristics differing from those of 

electromechanical equipment. 

Safety Guidelines for the Application, Installation and Maintenance of Solid State 

Controls describes some important differences between solid state equipment and 

hard-wired electromechanical devices. 

Because of this difference, and also because of the wide variety of uses for solid state 

equipment, all persons responsible for applying this equipment must ensure that each 

intended application of this equipment is acceptable. 

In no event will GE be responsible or liable for indirect or consequential damages 

resulting from the use or application of this equipment. 

The examples and diagrams in this manual are included solely for illustrative 

purposes. Because of the many variables and requirements associated with any 

particular installation, GE cannot assume responsibility or liability for actual use based 

on the examples and diagrams. 

Safety Notes 

Warning 

The modules are equipped with electronic components that may be 

destroyed by electrostatic discharge. When handling the modules, ensure 

that the environment (persons, workplace and packing) is well grounded. 

Avoid touching conductive components, for example, RSTi Bus Pin. 
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Certifications 

c-UL-us UL Listed Industrial Control Equipment, certified for U.S. and Canada 

See UL File E105285 

 

CE Mark 

EN 61000-6-2:2005; Industrial Immunity 

EN 61000-6-4:2007; Industrial Emissions 

Profinet certificate: Z10439 
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Government Regulations 
U.S., Canadian, Australian, and European regulations are intended to prevent 

equipment from interfering with approved transmissions or with the operation of other 

equipment through the AC power source. 

The PACSystems RSTi family of products has been tested and found to meet or 

exceed the requirements of U.S. (47 CFR 15), Canadian (ICES-003), Australian 

(AS/NZS 3548), and European (EN 61000-6-4:2007) regulations for Class A digital 

devices when installed in accordance with the guidelines noted in this manual. These 

various regulations share commonality in content and test levels with that of CISPR 

22 and based on this commonality testing to the each individual standard was 

deemed inappropriate. 

The FCC requires the following note to be published according to FCC guidelines: 

Note: This equipment has been tested and found to comply with the limits for a 
Class A digital device, pursuant to Part 15 of the FCC Rules. These limits are 
designed to provide reasonable protection against harmful interference when 
the equipment is operated in a commercial environment. This equipment 
generates, uses, and can radiate radio frequency energy and, if not installed 
and used in accordance with the instruction manual, may cause harmful 
interference to radio communications. Operation of this equipment in a 
residential area is likely to cause harmful interference in which case user will 
be required to correct the interference at his own expense. 

Industry Canada requires the following note to be published: 

Note: This Class A digital apparatus complies with Canadian ICES-003. 
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Environmental Specifications 

PROFINET STXPNS001  

 

Items Specification 

Environmental Specification 

Operating Temperature -20℃—50℃ for UL applications. -20℃ to 60℃ for non UL 
applications.  

Storage Temperature -25°C to 85°C 

Relative Humidity 90% Non-condensing 

Protection Class IP 20 

Mounting  DIN Rail 

 

PROFIBUS STXPBS001  

 

Items Specification 

Environmental Specification 

Operating Temperature -20℃—50℃ for UL applications. -20℃ to 60℃ for non UL 
applications.  

Non-Operating Temperature -40°C to 85°C 

Relative Humidity 5% to 90% Non-condensing 

Operating Altitude 2000m 

Mounting  DIN Rail 
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Abbreviations 
 

Items Description 

GND Ground 

GSD Generic Station Description 
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